I installed or uninstalled some packages. I do not even remember what I was doing. As a result, now I can't see most of the system settings in settings window. Any idea how to solve this problem.

enter image description here

When I hover mouse over the window title, it shows 'Unknown Application name' I must have removed something, not sure what :-)

  • 8
    I encountered the same problem after addressing problems with sound (following a suggestion to remove and reinstall alasbase and pulseaudio - this fixed my sound problem). Reinstalling ubuntu-desktop worked for me (and sound still working) – AnGus Jun 5 '14 at 0:44
  • Reinstalling ubuntu-desktop solved my sound problem which couldnt be helped by reinstalling alsa and pulseaudio. Thanks a lot – user294605 Jun 18 '14 at 9:17
  • 1
    Unity seems to have a (unjustified?) dependency on evolution; running sudo apt-get purge evolution* triggers this. To get the System Settings back without much evolution cruft, I ran sudo apt-get install unity-control-center --no-install-recommends afterwards, some evolution-related components get installed and System Settings with all of its icons is back. – Nickolai Leschov Oct 11 '15 at 15:01

You may have accidentally removed some packages (or some dependencies which caused the package to uninstall). In any case, you may try installing (or re installing) the package ubuntu-desktop. Correct any accidental package uninstallation by:

sudo apt-get install ubuntu-desktop
| improve this answer | |
  • 4
    same problem here Indigo and I was just playing with sound... thx cshubhamrao – Lukas Lukac Apr 29 '14 at 14:16
  • 17
    Also came a cross this problem wile experiencing sound problems and trying to fix them. Think it happened when I reinstalled alsa-base and pulsesound. – Thomas K Jul 10 '14 at 7:20
  • 34
    sudo apt-get install unity-control-center is probably all you need, not the entire ubuntu-desktop – David Underhill Aug 17 '14 at 0:36
  • 2
    @DavidUnderhill yes, but the OP may also have accidentally removed some more packages, installing the ubuntu-desktop is sure shot way to fix any more missing packages – cshubhamrao Aug 17 '14 at 15:42
  • 20
    I met this problem after I issues this command: apt-get remove --purge alsa-base pulseaudio – PhatHV May 27 '15 at 4:03

Uninstall and then reinstall System Settings (unity-control-center) from the Ubuntu Software Center application.

Or run this command in terminal

  1. sudo apt-get remove unity-control-center
  2. sudo apt-get install unity-control-center
| improve this answer | |
  • 11
    +1 This completely fixes the issue for me without reinstalling all the other stuff that comes with ubuntu-desktop, and is the best answer here. – Jason C Jul 7 '14 at 19:45
  • 1
    Did the trick for me, though line #1 said unity-control-center wasn't installed, but second line did it. I've been messing with my 14.04 Ubuntu recently, installed Cinnamon, removed some stuff, and disabled some services, etc, so no clue what cased settings appear like that, but i am pretty sure installing cinnamon played into it some how. Good answer, though -minimalistic and practical – Sergiy Kolodyazhnyy Nov 13 '14 at 6:15
  • Awesome, worked for me without reboot. I think I also lost settings when trying to deal with sound issues. – Rmurphy Nov 15 '19 at 17:00

If reinstalling ubuntu-desktop still doesn't cut it for you, you may be accessing system settings in a wrong way. Try to open them directly from a terminal (rather than a bogus shortcut like I was):

| improve this answer | |
  • Thank you for those using the gnome-desktop like me. Just couldn't remember the name for what needed to be removed and reinstalled. – Terrance May 26 '15 at 16:26

Yep removing a few programs as suggested BY Ubuntu left settings LOST.

and I had noticed in rem, moving the package, that it also removed gnome-control-center.

Re-installing it solved the problem! find it in software or alternatively type this in a terminal ...

sudo apt install gnome-control-center

Always Trying to help, Mark

| improve this answer | |
  • neither one of these solutions solved the settings issue. Only devices tab is shown in settings. – Brad Thompson Apr 21 at 18:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.