7

I upgraded from 13.10 to 14.04 a couple of days ago via internet using "sudo apt-get upgrade".

After the upgrade, both my wired connection and wireless connection stopped talking to the internet when using Firefox or Chrome.

I do not have any problem exchanging files with another PC (running Ubuntu 10.04) use Filezilla within the same network and am able to use Firefox to log into my router to check configuration.

What is so strange was the system appeared to be able to reach out to internet to download files when I run "sudo apt-get update".

I am really baffled by this. Any help to get me back my internet access for both wired/wireless connections would be appreciated.

Here's some information about my settings (wireless intentionally disabled when this snapshot is taken):

The unit is a ThinkPad T60.
ifconfig:
eth0  Link encap:Ethernet  HWaddr 00:15:58:7d:17:04  
      inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
      inet6 addr: fe80::215:58ff:fe7d:1704/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:162 errors:0 dropped:0 overruns:0 frame:0
      TX packets:167 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:50700 (50.7 KB)  TX bytes:24254 (24.2 KB)
      Interrupt:16 Memory:ee000000-ee020000 

lo    Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:228 errors:0 dropped:0 overruns:0 frame:0
      TX packets:228 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:57669 (57.6 KB)  TX bytes:57669 (57.6 KB)

sudo lshw -C network:
*-network               
      description: Ethernet interface
      product: 82573L Gigabit Ethernet Controller
      vendor: Intel Corporation
      physical id: 0
      bus info: pci@0000:02:00.0
      logical name: eth0
      version: 00
      serial: 00:15:58:7d:17:04
      size: 100Mbit/s
      capacity: 1Gbit/s
      width: 32 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt    10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
      configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.5-1 ip=192.168.1.102 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
      resources: irq:45 memory:ee000000-ee01ffff ioport:3000(size=32)
 *-network DISABLED
      description: Wireless interface
      product: PRO/Wireless 3945ABG [Golan] Network Connection
      vendor: Intel Corporation
      physical id: 0
      bus info: pci@0000:03:00.0
      logical name: wlan0
      version: 02
      serial: 00:18:de:b8:b1:c2
      width: 32 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=iwl3945 driverversion=3.13.0-24-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11abg
      resources: irq:47 memory:edf00000-edf00fff


route -n  (revised using dhcp):
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     1      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0
  • Hi & Welcome to AU. May I ask, whether you're able to ping website through the terminal.. Also, please post the output for route -n once connected either through LAN or WLAN. :) – AzkerM Apr 23 '14 at 7:51
  • Hi. Thanks for the reply. I cannot ping any website through Network tool or terminal. Does that mean a dns problem? – iseries_dev Apr 23 '14 at 23:24
  • Here's the output from 'route -n' (I updated the original thread in the code box). – iseries_dev Apr 24 '14 at 5:37
  • The route is based on the current setting (with static IP as recommended by @begueradj) – iseries_dev Apr 24 '14 at 5:43
  • @AzkerM, please note I updated the above route -n after switching back to use dhcp. Thanks. – iseries_dev Apr 24 '14 at 6:23
4
  1. In /etc/NetworkManager/NetworkManager.conf, change managed=false to managed=true.
  2. From the top-right corner select Edit Connections, and add a new connection. Specify your ip address, netmask, gateway, and the DNS server being 8.8.8.8.
  3. Then run: sudo service network-manager restart.
  • On Xbuntu after an upgrade I had the same issue: no network, kernel mod loaded, interfaces defined in ifconfig and lshw network, but nothing worked. I finally did steps 1 and 3 above and the network worked for me after that. – erewok Oct 8 '14 at 19:08
2

Edit correctly the following files:

/etc/network/interfaces
/etc/resolv.conf
/etc/hosts

In /etc/network/interfaces specify these information:

 auto ethX
    iface ethX inet static

    address
    netmask
    broadcast
    dns-nameserver
    gateway

ethX: X can be 0,1, 2 ... depending on the network interface you are using. But in your case it is eth0

In /etc/resolv.conf specify these information:

nameserver x.x.x.x

(you can add a new nameserver address on a new line)

In /etc/hosts add your username and address on the 3rd line as follows:

  yourUsername yourIPaddress

After you saved the 3 files, run this command:

sudo service network-interface restart INTERFACE=eth0
  • Thanks for your reply. If I were to define eth0 or wlan0 (my wireless connection) to use only DHCP, do I need to define dns-nameserver, broadcast and gateway? Also, I think the last command may contain a typo, should be: "sudo service network-interface restart INTERFACE=eth0" right? – iseries_dev Apr 23 '14 at 23:22
  • No, if you are using DHCP it will take care of the settings. Sorry, you are right, I had to write INTERFACE in the above commande which I just edited. – user284234 Apr 24 '14 at 5:29
  • How do I extract a syslog to post here so that you can help in diagnose what is happening to the internet access? – iseries_dev Apr 24 '14 at 5:44
  • You can run this command: cat /var/log/syslog – user284234 Apr 24 '14 at 5:48
  • Thanks. But it is a pretty large file. Do you want me to post the file in a link? or is there any particular part of the log that can help in this diagnosis? Please advise. – iseries_dev Apr 24 '14 at 6:19
1

After several tinkering of the settings with helps from various readers here, the situation had not been improved.

So, I eventually backed up all the important files and did a full install of 14.04. Now the system is capable of getting to the internet and internal networks. There are, however, a few "glitches" in 14.04 gnome comparing to 13.10. But at least I can use my system again.

Thank you for those who lent a helping hand.

1

I had the same problem with my WiFi connection , I tried to edit Newtworkmanager.conf but didn't work for me .

I went to edit connection and deleted my Wifi connection Then added it again and entered the password ...

and It fortunately work :)

  • According to the question the issue exists with the wired network connection as well, so any WiFi-related fixes are not going to work. – David Foerster Sep 26 '14 at 13:37
  • sorry, I thought he was talking about Wifi ,I didn't notice "the wired" connection. Apologies – Ahmed Aboulkomsan Sep 27 '14 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.