Since upgrading to Ubuntu 14.04, When I launch my VirtualBox virtual machine I get:

Failed to open a session for the virtual machine win7pro32bit.
Implementation of the USB 2.0 controller not found!
Because the USB 2.0 controller state is part of the saved VM state, the VM cannot be
 started. To fix this problem, either install the 'Oracle VM VirtualBox Extension Pack'
 or disable USB 2.0 support in the VM settings (VERR_NOT_FOUND).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

The solution to the same question for 12.10 does NOT fix the problem:

sudo apt-get purge virtualbox
sudo apt-get autoremove
sudo apt-get update
sudo apt-get install virtualbox

UPDATE: Also happens when upgrading VirtualBox itself to 5.0, within existing Ubuntu 14.04.

  • Also happens with USB 3.0 updating 6.1.30 to 6.1.32 — so slipshod.
    – Devon
    Commented Feb 14, 2022 at 22:05

3 Answers 3


Download and install VirtualBox extension pack from here(according to your VirtualBox version). It may solve your problem.

Because your error report says like that.

To fix this problem, either install the 'Oracle VM VirtualBox Extension Pack'
  • I got this error upgrading from Ubuntu 16.04 to Ubuntu 16.10, this fixed it ^^ Commented Nov 7, 2016 at 11:00
  • You can install it just by double clicking at the downloaded file
    – deFreitas
    Commented Mar 12, 2018 at 1:52
  • Make sure about the version of the VirtualBox installed at the host to install the Extension Pack.
    – testuser
    Commented Dec 9, 2019 at 11:22
  • 1
    To that, I wonder: if they know the error and the fix, what's holding them back to getting you the link to install it right away? Commented Jun 1, 2020 at 16:48

I tried to install a virtual machine with windows XP and had a similar error. So i deactivated the USB controller and the machine is working now.

Maybe this will help someone.

start virtualbox -> right click on a machine (the machine should powered off) -> settings and now look on the screenshot enter image description here

there you can enable/disable it.


If you can't start after upgrade, somewhere along the lines of...

A possible reason for this error is a missing extension pack. Note that as of VirtualBox 4.0, certain features... VERR_PDM_DEVICE_NOT_FOUND

  1. Download the version matching extension pack (there's only 1 link for the download, fit for all platforms): https://www.virtualbox.org/wiki/Downloads
  2. in your download folder (all in one line): $> sudo VBoxManage extpack install --replace Oracle_VM_VirtualBox_Extension_Pack-………….vbox-extpack
  3. important, also do: sudo VBoxManage extpack cleanup
  4. possibly a right-click „discard saved status“ (in case you „hibernated“ open&running VMs)
  5. re-starting your VMs should work now.(even w/o closing and opening the virtual box application, in my case)

Great advice found here.

  • This is, more or less, the same as the accepted answer from Apr 23 '14 ...
    – Soren A
    Commented Sep 6, 2018 at 9:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .