7

I have had some serious issues with my external monitor and graphics display since installing Ubuntu 14.04, and no one else seems to have had the exact same problem so I figured it best to post here.

I have a Dell Vostro 3500 dual-booting Windows 7 and Ubuntu 14.04 with Nvidia 310M hybrid graphics. Initial installed drivers with 14.04 caused persistent system program errors after booting, which was rectified by updating my drivers to nvidia-331-updates (http://packages.ubuntu.com/trusty/nvidia-331-updates).

Connecting my Asus external monitor via VGA has given me persistent errors/crashes, so I am trying to get the HDMI connection working as it will hopefully be more stable. Unfortunately when I connect the HDMI cable there is no output on the external monitor and my laptop screen immediately turns black, and remains black even after unplugging the HDMI leaving me no option but a hard reset. The HDMI connection works fine in Windows 7 under performance mode, which is what I have set in Ubuntu but perhaps there are other settings that need adjustment?

Guessing this is a graphics hardware/driver issue, which I know very little about so any comments/suggestions/advice in the matter would be greatly appreciated! Thanks in advance :)

Edit: Here are images of the xserver log file (in failsafe graphics mode w/ HDMI connected): http://imgur.com/slPUqxt,72fTA0i,6HISdyp,dimKobC,qUklr89,TXppP5v,kNk1yaG,zghEn4n,4jo53dL,EBTsDJ3#0 Based on the warnings/errors (img 2, 7, 8), seems like directories/files are missing.. does this shed light on my problem?

3
  • What are you using to connect HDMI to VGA?
    – Mitch
    Apr 23 '14 at 7:11
  • Just trying to connect via HDMI (without VGA), sorry if I was unclear
    – user270688
    Apr 24 '14 at 8:21
  • i have an asus X55A laptop with Intel Sandybridge graphics, when i plug a vga monitor or HDMI monitor my laptop's displays has some video errors and i can't tipe or click on anithing, i installed intel graphics instaler for linux, thinking maybe it fix it, but... i still have the same problem... i was thinking my intel graphics card was the problem but now i see nvidia has the same problem
    – user297005
    Jun 23 '14 at 3:49
1

Does HDMI1 and LVDS1 both show when you use xrandr in terminal?

If so you may be able to temporarily workaround it by using

xrandr --output LVDS1 --auto

If there's no errors the display should turn back on.

Also if you want xrandr with a gui you can use arandr:

sudo apt-get install arandr

6
  • xrandr shows I have HDMI-0, LVDS-0, HDMI-1-0 and LVDS-1-0, and LVDS-1-0 is the only one that is connected. I tried "xrandr --output LVDS-1-0 --auto" without any errors, but plugging in the HDMI still causes my main display to blackout and no change on the external monitor... Would I need to have the HDMI already plugged in for this to have any effect? I am at a loss since I have no way of seeing what happens when the HDMI is connected...
    – user270688
    Apr 24 '14 at 8:36
  • So opening a new terminal with the HDMI connected, will the terminal render on the blanked out display? I think it may just be physical limitations of the buffer. Does the display flicker after blanking out? You could maybe try lower resolutions on one of them to see if it is limitations to the virtual buffer. How old is the video card?
    – DWils
    Apr 24 '14 at 14:50
  • So when I boot Ubuntu with HDMI connected the peculiar thing is that everything seems normal up to the login screen, but after logging in the laptop screen goes black (and stays black even if HDMI is unplugged). Booting Ubuntu without the connection is normal, but then plugging the HDMI in after everything has loaded causes the same blackout result... No flickering occurs. I'll try lower res to see if anything changes. I bought the laptop early 2011, but it was an outlet purchase so perhaps an older video card?
    – user270688
    Apr 24 '14 at 18:56
  • hmm.. lowering the resolution merely shrinks the portion of the screen occupied by the graphical display, so it seems like the resolution is somehow fixed... but no change in HDMI problem. Here are images of the xserver log file (in failsafe graphics mode w/ HDMI connected): imgur.com/… Based on the warnings/errors (img 2, 7, 8), seems like directories/files are missing.. does this shed light on my problem?
    – user270688
    Apr 24 '14 at 20:33
  • That just means you're using defaults, indicated by the (==). Now as far as I understand the reason you can see it on login and not after is that on the login it's cloning the display, and your video card may be having issues supporting the virtual space required to spread across multiple displays (hence my suggestion to reduce resolution). I had this issue when trying to create a virtual space across 3 displays on hdmi/lvds/vga, and still haven't been able to. Have you tried it in arandr? That usually gives me a good idea if it will work before applying.
    – DWils
    Apr 24 '14 at 22:08
1

I had the same "problem" (regarding the laptop lid), the solution is simple: you have to raise the screen brightness, I don't know why but when I plug the HDMI the brightness of the laptop lid is set to 0 and it seems that the screen is turned off.

1

I had the same problem and I solved it by changing the Nvidia driver. I put the proprietary driver, and since then everything works.

1
  • 2
    Can you improve your answer and include the process or steps in which you changed the Nvidia drivers and put the proprietary ones..
    – Parto
    Jul 21 '14 at 12:51
1

This worked for me:

  1. Disconnect the HDMI

  2. Install arandr:

    sudo apt-get install arandr
    
  3. Reconnect HDMI

1
  • Worked for me as well
    – Ludwik
    Aug 15 '16 at 9:12
0

with my 14.04 and my tv connected to the hdmi port SYSTEM SETTINGS DISPLAYS Your computer monitor and tv should be shown. select your computer monitor then check mirror displays your monitor and tv should show the same .

For sound: click on the speaker Sound settings click on HDMI/DISPLAY PORT you should have sound on the tv but not the computer

0

With the installation of the Nvidia driver in Ubuntu distros, a second portion is also installed which provides control over the setting for your Nvidia card and its outputs, nvidia-settings.

In nvidia-settings you will find "X Server Display Configurations" and there, within the Display tab you can select your HDMI device, change its resolution to your desired resolution and its response time to your device's ability: 50Hz if outside North America, 60Hz in North America. Note that it may show 59.xx as the NA 60Hz claim is just rounding the actual 59.xxHz to 60Hz.

You can then select the other display device and change its settings in X Server Display Configuration to "Resolution" = "Off" and "Configuration" to "Off" if you do not wish to use it while using your HDMI, or change "Configuration" to Twin View for the same video on both, or make it a side-by-side screen so that you can use both at the same time. In addition, you may wish to move to the X Video tabs on the left and change things to your liking.

Lastly, you should move over to the "GPU 0 (Nvidia 310M)" and select the item which is your HDMI display and change to settings to make them best suite your viewing pleasure.

With NVidia-331-updates driver installed your fix is easy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.