17

I am not able to put my laptop to suspend(sleep) mode,If I click on suspend it just locks the screen and nothing happens ?

I updated my previous version of UBUNTU from 13.04 to 13.10 then to 14.04

Any Idea why this is happening or any work around to fix the issue ?

I am using DELL VOSTRO 3400 with 64 bit OS

  • Hello, and welcome to AskUbuntu ;) Well, could you try to open up your terminal ctrl+alt+t and use this command, to see if it works: sudo pm-suspend – Denny Apr 23 '14 at 6:11
  • I also reported similar issue: askubuntu.com/questions/452605/… – Andrej Apr 23 '14 at 11:31
  • You may want to check out and follow bugs.launchpad.net/ubuntu/+source/linux/+bug/1315435 – Dennis May 4 '14 at 20:23
  • I tried the script on 14.04 on a VAIO pro 13 flip . I finally get a resume instead of a black screen but I lost my mouse and my pad so it is useless. any ideas? – kwoby May 14 '14 at 13:54
  • Do you have an AMD/ATI Graphics card? – Devesh Khandelwal May 29 '14 at 4:58
5

You're possibly seeing this bug: Black screen after login from suspend in Xubuntu 14.04. Try removing light-locker and light-locker-settings and installing xscreensaver to solve the issue of buggy suspend/resume.

| improve this answer | |
  • I am not using any of these packages ? – Lohith MV Apr 25 '14 at 18:08
  • OK, then you're likely seeing something else. – landroni Apr 25 '14 at 23:17
  • I tried this and the issue still persists. – Christophe De Troyer May 2 '14 at 9:03
  • @ChristopheDeTroyer If you're seeing a specific issue, please ask a separate question describing the symptoms. – landroni May 2 '14 at 12:35
  • 1
    @ChristopheDeTroyer The original question is not that very clear, actually. It doesn't state the DE used, the power manager, the locker nor the screensaver.. – landroni May 2 '14 at 12:38
1

I have this problem after I used a different kernel version yesterday. Although I still don't know why it occurs, the following way may help you fix the problem.

To debug this problem is to run pm-suspend from terminal and check if there's something wrong by analyzing /var/log/pm-suspend.log.

For my case, a program which exit abnormal stopped the suspending. After I removed it, the suspend works again.

Running hook /etc/pm/sleep.d/soxy suspend suspend: 
Stopping Soxy proxy on port 7070       
No running Soxy process found
/etc/pm/sleep.d/soxy suspend suspend: Returned exit code 1.

Thu Sep 10 21:39:11 CST 2015: Inhibit found, will not perform suspend
Thu Sep 10 21:39:11 CST 2015: Running hooks for resume
| improve this answer | |
0

I got 'suspend' working after and update from Ubuntu 12.04 LTS to 14.04 LTS ( Sony Vaio VPCEB1E0E ).

I had previously used the script below on my Ubuntu 12.04 LTS: [source http://ubuntuforums.org/showthread.php?t=1978290&p=11958911#post11958911]

#!/bin/sh
#inspired by http://art.ubuntuforums.org/showpost.php?p=9744970&postcount=19
#...and http://thecodecentral.com/2011/01/18/fix-ubuntu-10-10-suspendhibernate-not-working-bug    
# tidied by tqzzaa :)

VERSION=1.1
DEV_LIST=/tmp/usb-dev-list
DRIVERS_DIR=/sys/bus/pci/drivers
DRIVERS="uhci_hcd xhci_hcd"
HEX="[[:xdigit:]]"
MAX_BIND_ATTEMPTS=2
BIND_WAIT=0.1

unbindDev() {
  echo -n > $DEV_LIST 2>/dev/null
  for driver in $DRIVERS; do
    DDIR=$DRIVERS_DIR/${driver}
    for dev in `ls $DDIR 2>/dev/null | egrep "^$HEX+:$HEX+:$HEX"`; do
      echo -n "$dev" > $DDIR/unbind
      echo "$driver $dev" >> $DEV_LIST
    done
  done
}

bindDev() {
  if [ -s $DEV_LIST ]; then
    while read driver dev; do
    DDIR=$DRIVERS_DIR/${driver}_hcd
    while [ $((MAX_BIND_ATTEMPTS)) -gt 0 ]; do
          echo -n "$dev" > $DDIR/bind
          if [ ! -L "$DDIR/$dev" ]; then
            sleep $BIND_WAIT
          else
            break
          fi
          MAX_BIND_ATTEMPTS=$((MAX_BIND_ATTEMPTS-1))
      done  
    done < $DEV_LIST
  fi
  rm $DEV_LIST 2>/dev/null
}

case "$1" in
  hibernate|suspend) unbindDev;;
  resume|thaw)       bindDev;;
esac

On Ubuntu 14.04 LTS, I changed the 'DRIVERS' line from: DRIVERS="ehci xhci" to: DRIVERS="uhci_hcd xhci_hcd" as was the case in the '/sys/bus/pci/drivers' directory.

The next thing I did was to edit the file '/etc/default/grub' (as root), changing the GRUB_CMDLINE_LINUX="" line to GRUB_CMDLINE_LINUX="acpi_sleep=nonvs".

Then running sudo update-grub.

[source Suspend fails (reboot on resume) and no hibernate option ]

These above set of steps did the trick for me.

Hope it helps.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.