0

I am now facing a problem in installing Ubuntu 12.04 LTS alongside windows 7. First of all, here is my pc configuration:

  • Intel desktop board DB75EN,
  • Intel i-5 3450 processor,
  • 1 TB Western Digital Hard disk,
  • 6 GB ram,
  • nvidia 8400gs graphics card.

Firstly I was able to make a dual boot system. But there was a problem in my motherboard with the on board graphics. So I get back to Intel and they replace it in 12 days. Now I have to do a fresh installation. Now I first install Windows 7. When I am going to install Ubuntu 12.04, the "Install Ubuntu alongside Windows 7" option was not there.Then I go with the "Try Ubuntu" option. While opening Gparted, it shows a 1TB unallocated space in the hard disk.

I format again the whole hard drive and make new partition table with Windows 7 bootable USB drive and leave a 200Gb unallocated space. But it failed with the same option. It failed recognize the previously installed Windows 7.

I search the forum...

I ran the command:

sudo parted -l

And I get the following output:

Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables.  Or perhaps you deleted the GPT table, and are now using an
msdos partition table.  Is this a GPT partition table?
Yes/No? y




Model: ATA WDC WD10EZEX-22B (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start  End  Size  File system  Name  Flags


Model: hp v112b (scsi)
Disk /dev/sdb: 8047MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      31.7kB  8046MB  8046MB  primary  fat32        boot, lba

What should I do?

0

It seems that you tried to convert a GUID Partition Table (GPT) disk to a Master Boot Record (MBR) disk but you did not complete the operation, and so you now have some hybrid partition table which can be accessed by Windows only. Ubuntu does not deal well with GPT as I understand.

There could be some solution for your problem on this link. I have an older computer so I can't say it will work or not for you.

If it does not, you can use gdisk which is designed to work on GUID Partition Table (GPT) disks, and automatically convert your partition table from MBR to GPT format thus restoring your original disk configuration. It would be better to ask a pro to help you with this one, do you still benefit for support from your manufacturer? This won't be easy if you try do it yourself.

Or you can use FixParts to replace your GUID Partition Table (GPT) with a Master Boot Record (MBR) partition table type. I am not sure at all if the download links provided on that page are still working for FixParts. There is a complete tutorial on how to use FixParts but the download links work some time and other time they do not. You can download Fix parts for Windows as I understand you have Win7 installed on your computer.

It is important to understand that you cannot use both methods, you have to either fix your partition table with GDISK or with FixParts but you cannot test them both. So it is up to you, and I strongly recommend you ask someone, a friend with good computing skills or a proffesional, maybe your computer manufacturer for advice. Tell them you want to install Windows and Ubuntu, and that you want to use a multiboot configuration on your computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.