2

I am using Ubuntu 13.10 and a wireless internet from a modem "Reliance Netconnect" for the internet.

I've installed Ubuntu two days back along with my Windows system.

So here's a detailed summary of what happens:

I open my computer, the internet connects after I go to the top-right corner, select the signal logo and click on the "Reliance connection" (the only connection for internet on the PC).

It connects immediately and says "You're registered on the home network." and the internet works fine. However, each time I've opened my computer and connected, there's this problem: it automatically disconnects after a while (which is around 5-10 minutes I think).

Let me rephrase: it connects all fine and then disconnects by itself after a while of usage.

Now comes the main problem. NO MATTER HOW MANY TIMES I TRY TO CONNECT IT THROUGH THE SAME SIGNAL LOGO, IT JUST WON'T CONNECT EVER.

It only works when I open it again later and because now I know that rebooting does the trick (well it merely refreshes everything), I reboot to reconnect to internet.

Now, as anyone would tell you, rebooting is not a viable alternative to reconnecting.

What's surprising is I Googled it and not many people have this problem. On two separate threads, people first asked for full details about their modem and networks, drivers, etc. but weren't able to help at all.

I am writing this long piece because I am using my Windows at the moment. Please help me. I don't want to come back to Windows. Ubuntu is so awesome. Everything else is so attractive and I've set up fine. Just this problem is forcing me to leave Ubuntu - or any Linux for that matter. Please.

3
  • Have you tried removing modem and reconnecting it? Apr 23 '14 at 4:23
  • Similar to the above... try clicking on the network icon in the panel, and deselect "enable networking", then reselect it. I sometimes need to do that. Jun 13 '14 at 4:16
  • Dear sirs. I am not a noob. I am fairly experienced too. I would've tried reinstalling, removing, reinserting... all the re's you can think of. c:
    – Abhimanyu
    Jun 13 '14 at 11:14
0

I didn't find any answers for this, thus no solution, but there seems to be a quick trick that I recently found.

I thought I may share this so that people experiencing the problem will be partially helped at least.

After you're done on your computer, disconnect the internet from the 'Signal' or networks menu on topbar. In the end of the same list, there will be Edit Connections/just Edit. The first step isn't necessary, but recommended.

Click on the Edit/Edit Connections. A window will open, titled Network Connections. Under Mobile Broadband segment, you'll see the connections you've made. Delete them all. ALL. (Not the Ethernet ones, that's unnecessary.)

So, basically, before shutting down, if you delete all your connections (now I only have one, because I make one each time I log on), next time you open the computer and create a fresh connection, your internet won't disconnect like that.

Note that you have to create the new connections from Settings>Network>Mobile Broadband dialog boxes, not through the same Network Connections window that you accessed from the network menu in the top bar.

Once you do this, and make a new connection every time (with username and password if needed), your internet will remain connected as long as the computer runs.

You can disregard the following part.

Suppose you don't do it, now what happens is this: The existing connection remains on the system. Probably because your mobile broadband dongle/modem are older and/or slightly incompatible with Ubuntu, the connections don't refresh and there seems to be some sort of problem in the system in reconnecting ONCE THEY DISCONNECT.

The old connections remain there and may connect on new session/startup, but they randomly disconnect for IDK why and then cannot be reconnected because of bad configuration that you cannot change with regular tweaks.

Even if you delete your connections and make a new one on a session which has booted with some/one connection(s) already there, it doesn't work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.