14

I'm new to Ubuntu and Linux in general and I'm not sure how to go about setting up my wifi. It doesn't detect any networks.

I'm using a late-2013 13.3" macbookpro with retina display, so it doesn't come with an ethernet port. I used this installation guide to dual boot Mac OSx and Ubuntu 14.04.

https://help.ubuntu.com/community/MacBookPro11-1/Saucy

I have a second computer that runs windows 7 that I'm using to research this and I want to avoid purchasing an ethernet adapter if possible.

I also did not install/download any of the updates as a result.

  • can you post output of rfkill list? also do sudo lshw -C Network and check that Wireless interface is detected. – Back.Slash Apr 23 '14 at 0:38
  • rfkill list 0: hci0: Bluetooth Soft blocked: no Hard blocked: no sudo lshw -C Network *-network UNCLAIMED description: Network controller product: BCM4360 802.11ac Wireless Network Adapter vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:03:00.0 version: 03 width: 64 bits clock: 33Mhz capabilities: pm msi pciexpress bus_master cap_list configuration: latency=0 resources: memory: b0600000-b0607fff memory: b0400000-b05fffff ...is what it says. – user272776 Apr 23 '14 at 2:43
  • You should accept chili555's answer. It worked perfectly for me. – Phani Oct 26 '14 at 22:05
30

Please run:

lspci -nn | grep 0280

The pipe symbol | is on the right side of my US keyboard on the same key with '\'. Is this your device?

Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)

If so, then bcmwl-kernel-source is correct for your device. If you still have the install DVD or USB, then you can find it and its prerequisite there. Navigate to pool > restricted > b > bcmwl and drag and drop the deb file to your desktop. Now navigate to pool > main > d > dkms and drag and drop dkms to your desktop. Now install both with:

cd ~/Desktop
sudo dpkg -i *.deb

Load the driver:

sudo modprobe wl

Your wireless should now be working.

If your device is not 14e4:43a0, tell us what it actually is and we'll proceed.

| improve this answer | |
  • 1
    So, I finally got my wifi up and running. I gave in and purchased an ethernet adapter. I gained access to the internet and tried sudo apt-get install bcmwl-kernel-source again and I still received a message saying it was unable to locate package. I found the package on ubuntuupdates.org/package/core/trusty/restricted/base/… and downloaded the 64-bit deb package. I tried the code again, and it worked this time. If I had tried the solution @chili555 had posted, I"d probably get the same result, since I had to download the package first. – user272776 Apr 25 '14 at 18:33
  • Amazing solution @chili555. Thanks. I can confirm that this solution also works for 14e4:4331 (rev 02) – hadi Nov 6 '14 at 7:52
  • 1
    Thanks so much!! If I could I would give you one million dollar. You saved my day. – Sigur Nov 6 '14 at 18:06
  • sudo apt-get install bcmwl-kernel-source works like a charm (MacBook Pro reina late 2013, using thunderbolt eth adapter) – Cesar Apr 12 '15 at 15:42
  • This does not work for me. Tried all of the above apart from apt install because I don't have USB/thunderbolt Ethernet. Ubuntu 14.04.2 on macbook pro late 2013. – Rob Apr 22 '15 at 22:26
5

Possible Solution Copied from Installing Broadcom Wireless Drivers

  • Uninstall the bcmwl-kernel-source package by issuing the following command on a terminal:

    sudo apt-get remove bcmwl-kernel-source
    
  • make sure that the firmware-b43-installer and the b43-fwcutter packages are installed (of course you will need internet by others means):

    sudo apt-get install firmware-b43-installer b43-fwcutter
    
  • type into terminal:

    cat /etc/modprobe.d/* | egrep 'bcm'
    

    (you may want to copy this) and see if the term 'blacklist bcm43xx' is there

  • if it is, type cd /etc/modprobe.d/ and then sudo gedit blacklist.conf

    put a # in front of the line: blacklist bcm43xx

    then save the file (I was getting error messages in the terminal about not being able to save, but it actually did save properly).

  • reboot

After I did the above the wireless had to be unblocked by rfkill: How to unblock something listed in rfkill?

| improve this answer | |
  • I tried to follow the guide that I used to install ubuntu with and it said to use sudo apt-get install bcmwl-kernel-source to install broadcom's driver and i get Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package bcmwl-kernel-source I get a similar response when I tried the first step you listed. is it safe to assume any attempt to sudo apt-get install ... will fail (since most of the solutions from that thread require that)? Is there no other way to get around this than get an ethernet adapter? Thanks!! – user272776 Apr 23 '14 at 3:27
  • you were trying to install bcwl-kernel-source using apt-get, now you are removing bcwl-kernel-source using apt-get so you can try doing this as lot of users have faced problem with Broadcomm Wireless Modules. So i would say give it a shot but again its your wish – Back.Slash Apr 23 '14 at 3:31
  • @Back.Slash-- There is no module named bcm43x; why un-blacklist it? Is it bcwl or bcmwl? – chili555 Apr 23 '14 at 13:43
  • just do find indocument of bcm43, if you dont have bcm43** then skip that step. that step applies only if /etc/modprobe.d/blacklist.conf has blacklisted bcm43xx. But in your case that seems not to be the case – Back.Slash Apr 23 '14 at 13:47
  • sudo apt-get install firmware-b43-installer b43-fwcutter was enough to get me going after a clean install of 14.04.2. – John Jelinek Feb 20 '15 at 21:43
2

Please make sure you buy a ETHERNET adapter to connect your mac to the internet. Then do the fallow steps bellow to make the WI-FI work...

After spending the entire weekend on trying to get the wifi to work on my mac-book air, I finally installed and got the WI-fi working by just typing on the terminal sudo apt-get install bcmwl-kernel-source and after type sudo modprobe wl to load the file.... Hope that works for you...

| improve this answer | |
0

I have a similar problem, namely the wifi running under Ubuntu 14.04 on a 10,2 (early 2013) macbook retina pro, is intermittent and drops connections. This results in vnc being cut off.

I tried the above and found that while I was able to change drivers, the above driver still drops wifi connections. Very irritating and hard to diagnose as the WiFi works perfectly then, for apparently no reason, loses its connection with no indicator on the front panel. After a few minutes, the connection recovers - or one can make it recover by shutting down and restarting the wireless.

I've filed a bug report with Launchpad.

The frustrating thing about all this is that under Ubuntu 13.04, the wireless worked flawlessly. Unfortunately, the problem appeared at Ubuntu 13.10 and I was forced to move away from 13.04 due to Heartbleed not being fixed on 13.04 and I use an openssl secured VPN with my machines.

Is this a driver issue or a kernel-driver interaction issue? If it's just the driver, I'd really like for them to go back to the 13.04 driver on 14.04 until they fix the new driver. Thanks, Phil

| improve this answer | |
  • Mmm, I don't know much about this, but I did get my wifi to work on my 11,1 macbook with 14.04 trusty tahr with no problems at all. I don't think it's a driver issue. – user272776 May 1 '14 at 21:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.