0

The method I utilized to disable Bluetooth and IVP6 in Lubuntu 13.10 apparently does not work in Lubuntu 14.04. Attempted three times and all three times I could not even boot to Desktop. Error messages.

In 13.10 I did the following:

sudo gksudo leafpad /etc/modprobe.d/blacklist.conf

blacklist ipv6

blacklist rfcomm

blacklist bnep

blacklist btusb

blacklist bluetooth

sudo gksudo leafpad /etc/modprobe.d/blacklist-rare-network.conf

Disable Bluetooth

alias net-pf-31 off

The above method worked fine in 13.10. When I attempt the same method in 14.04 I get error messages upon boot that the entries are being ignored. However the screen just stays frozen on the messages. When I do a cold reboot and go into recovery mode, choose root and attempt to remove the entries I get an error message stating that leafpad cannot be accessed or something to that effect. So I have to start over again with a clean install.

Please advise if possible. Maybe IVP6 and Bluetooth cannot be disabled in 14.04? Is there a way to prevent start-up of both rather than a full disable?

0

You should be able to use sysctl configuration to disable IPv6. I don't have bluetooth configured, but there may be parameters for it as well. Try sysctl -a to get a list of parameters.

This is the contents of my /etc/sysctl.d/80-disable-ipv6.conf. I have IPv6 enabled, so the settinges are commented out.

# 80-disable-ipv6.conf

#net.ipv6.conf.default.disable_ipv6 = 0
#net.ipv6.conf.all.disable_ipv6 = 0
#net.ipv6.conf.lo.disable_ipv6 = 0
#net.ipv6.conf.eth0.disable_ipv6 = 0

#net.ipv6.conf.default.use_tempaddr = 0
#net.ipv6.conf.all.use_tempaddr = 0
#net.ipv6.conf.lo.use_tempaddr = -1

# EOF
|improve this answer|||||
  • Thank you for your input. I will try the contents you provided. I attempted a sixth time to operate Lubuntu 14.04 and, without doing any changes at all, I accessed the LXTerminal and got the following error messages: 1) sudo: command not found 2) sudo leafpad: command not found 3) sudo apt-get: command not found. I get the same error messages typing the commands in the Grub Recovery Mode (root). For example sudo leafpad /etc/default/grub come back with error message: sudo leafpad: command not found – user236378 Apr 23 '14 at 5:58
  • @user236378 The command not found message indicate that the program is either not installed, or is not on the search path. In this case it appears the missing command is sudo. Try running sudo -i to verify. – BillThor Apr 23 '14 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.