I installed the Gambit Scheme with the source from here as follows:

cd gambcfolder...
./configure --enable-single-host
sudo make install

But something is wrong. When I run gsi I get an error:

The program 'gsi' is currently not installed. 
You can install it by typing: sudo apt-get install gambc

I had installed gambc from the repository, but I had some problems using SLIB, so I removed it.


1 Answer 1


Remove old link in the /usr/bin

 sudo rm /usr/bin/gsi

Make new Link

 ln -s ~/Downloads/gambc-v4_6_0/gsi/gsi /usr/bin/gsi

And enjoy

  • I tried it: bash: /usr/bin/gsi: No such file or directory Apr 22, 2014 at 23:28
  • did you do sudo updatdb before locate gsi and locate gambit in pastebin.com/gz25ANC9 ?
    – Back.Slash
    Apr 22, 2014 at 23:29
  • Yes, I did. What can I do? Apr 22, 2014 at 23:32
  • can you do cd /usr/bin and ls | grep "gsi" and check if gsi is infact there
    – Back.Slash
    Apr 22, 2014 at 23:34
  • This returned the gsi name in red. Apr 22, 2014 at 23:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.