I tried to install Teamviewer 9 on Ubuntu 14.04, unsuccessfully.

I've downloaded the following extra(Raring) packages:

http://archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs-multiarch_20090808ubuntu36_i386.deb
http://archive.ubuntu.com/ubuntu/pool/universe/i/ia32-libs/ia32-libs_20090808ubuntu36_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.25-4ubuntu3.1_i386.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.25-4ubuntu3.1_amd64.deb
http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/lib32asound2_1.0.25-4ubuntu3.1_amd64.deb
http://www.teamviewer.com/en/download/linux.aspx

But these errors were happened while I was installing the packages (I've also tried install with Ubuntu's Software Center, the same):

$ sudo dpkg -i *.deb


Selecting previously unselected package ia32-libs.
(Reading database ... 254553 files and directories currently installed.)
Preparing to unpack ia32-libs_20090808ubuntu36_amd64.deb ...
Unpacking ia32-libs (20090808ubuntu36) ...
Selecting previously unselected package ia32-libs-multiarch.
Preparing to unpack ia32-libs-multiarch_20090808ubuntu36_i386.deb ...
Unpacking ia32-libs-multiarch (20090808ubuntu36) ...
Selecting previously unselected package lib32asound2.
Preparing to unpack lib32asound2_1.0.25-4ubuntu3.1_amd64.deb ...
Unpacking lib32asound2 (1.0.25-4ubuntu3.1) ...
dpkg: warning: downgrading libasound2:amd64 from 1.0.27.2-3ubuntu7 to 1.0.25-4ubuntu3.1
Preparing to unpack libasound2_1.0.25-4ubuntu3.1_amd64.deb ...
De-configuring libasound2:i386 (1.0.27.2-3ubuntu7) ...
Unpacking libasound2:amd64 (1.0.25-4ubuntu3.1) over (1.0.27.2-3ubuntu7) ...
Replaced by files in installed package libasound2-data (1.0.27.2-3ubuntu7) ...
dpkg: warning: downgrading libasound2:i386 from 1.0.27.2-3ubuntu7 to 1.0.25-4ubuntu3.1
Preparing to unpack libasound2_1.0.25-4ubuntu3.1_i386.deb ...
Unpacking libasound2:i386 (1.0.25-4ubuntu3.1) over (1.0.27.2-3ubuntu7) ...
Replaced by files in installed package libasound2-data (1.0.27.2-3ubuntu7) ...
Selecting previously unselected package teamviewer.
Preparing to unpack teamviewer_linux_x64.deb ...
Unpacking teamviewer (9.0.27891) ...
More than one copy of package libasound2:i386 has been unpacked
 in this run !  Only configuring it once.
dpkg: dependency problems prevent configuration of ia32-libs-multiarch:
 ia32-libs-multiarch depends on bluez-alsa; however:
  Package bluez-alsa:i386 is not installed.
 ia32-libs-multiarch depends on libgettextpo0; however:
  Package libgettextpo0 is not installed.
 ia32-libs-multiarch depends on gstreamer0.10-plugins-good; however:
  Package gstreamer0.10-plugins-good:i386 is not installed.
 ia32-libs-multiarch depends on gtk2-engines; however:
  Package gtk2-engines is not installed.
 ia32-libs-multiarch depends on gtk2-engines-murrine; however:
  Package gtk2-engines-murrine is not installed.
 ia32-libs-multiarch depends on gtk2-engines-pixbuf; however:
  Package gtk2-engines-pixbuf is not installed.
 ia32-libs-multiarch depends on gtk2-engines-oxygen; however:
  Package gtk2-engines-oxygen is not installed.
 ia32-libs-multiarch depends on ibus-gtk; however:
  Package ibus-gtk is not installed.
 ia32-libs-multiarch depends on libaio1; however:
  Package libaio1:i386 is not installed.
 ia32-libs-multiarch depen
dpkg: error processing package ia32-libs-multiarch (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasound2:amd64:
 libasound2-data (1.0.27.2-3ubuntu7) breaks libasound2 (<< 1.0.27-4) and is installed.
  Version of libasound2:amd64 to be configured is 1.0.25-4ubuntu3.1.

dpkg: error processing package libasound2:amd64 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libasound2:i386:
 libasound2-data (1.0.27.2-3ubuntu7) breaks libasound2 (<< 1.0.27-4) and is installed.
  Version of libasound2:i386 to be configured is 1.0.25-4ubuntu3.1.

dpkg: error processing package libasound2:i386 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ia32-libs:
 ia32-libs depends on ia32-libs-multiarch; however:
  Package ia32-libs-multiarch is not configured yet.

dpkg: error processing package ia32-libs (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lib32asound2:
 lib32asound2 depends on libasound2 (= 1.0.25-4ubuntu3.1); however:
  Package libasound2:amd64 is not configured yet.

dpkg: error processing package lib32asound2 (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of teamviewer:
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not configured yet.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not configured yet.

dpkg: error processing package teamviewer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ia32-libs-multiarch
 libasound2:amd64
 libasound2:i386
 ia32-libs
 lib32asound2
 teamviewer

Do someone know how to install the Teamviewer on 14.04?

marked as duplicate by Radu Rădeanu, antivirtel, karel, Eric Carvalho, Avinash Raj Apr 24 '14 at 3:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Why don't you use Ubuntu's Software Center to install TeamViewer (by double clicking the .deb)? The Software Center will automatically resolve and install the dependencies for you. – Louis Matthijssen Apr 22 '14 at 20:31
  • Sorry, I've forget to mention in the question. I've tried from that Ubuntu's Software Center too! – antivirtel Apr 22 '14 at 20:44
  • I had the same problem as you with 64-bit of team viewer, just try 32-bit and you will be fine. – Mohammad_Hosseini Apr 22 '14 at 21:03
  • 1
    @Braiam showed in his answer: First, download the 32 bit version: wget http://www.teamviewer.com/download/teamviewer_linux.deb - First, install gdebi: sudo dpkg --add-architecture i386; sudo apt-get update; sudo apt-get install gdebi In the same directory you downloaded the .deb file just run: sudo gdebi teamviewer_linux.deb – rubo77 Jun 29 '14 at 8:41
up vote 107 down vote accepted

As of Ubuntu 11.10, there is no longer an ia32-libs package. Because of this, older x64 packages (such as the x64 version distributed on their site) will no longer be able to install.

TeamViewer has since removed the x64-only download, and they only offer the i386 version.

To install TeamViewer now, it's as simple as visiting the official download page, clicking the "Download" button, and then running the downloaded .deb file.

If you want to use the terminal for this operation, that's still doable:

  1. Grab the TeamViewer debfile:

     wget https://download.teamviewer.com/download/teamviewer_i386.deb
    
  2. Install the downloaded DEB file:

     sudo dpkg -i teamviewer_i386.deb
    
  3. If DPKG throws any errors, fix any dependency issues to make sure everything works fine:

     sudo apt update && sudo apt -f install
    

TeamViewer will now be ready for use and will be present in your menu.

  • 1
    Oh yeah, you're right! Thank you. Otherwise, it is just a temporary solution. I'm looking forward to run the TV without Multiarch, and Mono/Wine, but natively on amd64! – antivirtel Apr 22 '14 at 22:49
  • 1
    Bad idea. TeamViewer 64bit was made for non-multiarch systems. In essence, it was the same product, requiring ia32-libs (which is gone). Teamviewer needs Wine/Mono as that is how the code is written. No way around it. – Kaz Wolfe Apr 22 '14 at 22:51
  • 1
    Ok, then I'll try to create a "mirror" PPA. – antivirtel Apr 22 '14 at 23:01
  • 1
    @shgnInc Because of Multiarch. TeamViewer was written for 32bit, and the 32bit files has no differences from the 64bit file, save for a few dependencies. – Kaz Wolfe Oct 20 '14 at 16:40
  • 1
    I got some errors: pastebin.com/HeUyhAuh it's 32bit version on ubuntu x64 14.04. Actually TreamViewer used to work months ago. But I had to upgrade to new version because on Win 8 PC it upgraded by itself. So Now it is not working at all. Just I can't install it – Tosho Feb 21 '15 at 21:51

Make sure you have wine installed, just like the answer in the link provided by @B. Roland. Wine is needed, because TeamViewer uses some.dll libraries provided by wine.

  • I've already had Wine(1.6) installed. Your answer didn't help, sorry and thank you. Please test your answers first! – antivirtel Apr 22 '14 at 21:52
  • Have you tried installing the dependencies that always helps. Package 'bluez-alsa:i386 is not installed. Package libgettextpo0 is not installed. ia32-libs-multiarch depends on gstreamer0.10-plugins-good; however: Package gstreamer0.10-plugins-good:i386 is not installed. Package gtk2-engines is not installed. Package gtk2-engines-murrine is not installed. Package gtk2-engines-pixbuf is not installed. Package gtk2-engines-oxygen is not installed. Package ibus-gtk is not installed. Package libaio1:i386 is not installed.' – oscarMg Apr 25 '14 at 13:43
  • wine is for "exe" files, teamviewer comes with preconfigured wine version, so - simply use 32 bit version – Rodislav Moldovan May 13 '14 at 19:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.