7

As the title says, since upgrading to 14.04, my wifi connection has been periodically hanging then dropping every 10min to hour. It will not reconnect unless I bring the adapter down and back up. So far I've tried upgrading the firmware for the adapter, making sure power management is off.

Here is relevant stuff. Thanks in advance for any help!

sudo lshw -C network
  *-network               
       description: Wireless interface
       product: Centrino Wireless-N 1030 [Rainbow Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 34
       serial: 4c:80:93:87:4c:ae
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-24-generic firmware=18.168.6.1 ip=192.168.0.191 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:30 memory:d0600000-d0601fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 05
       serial: 84:8f:69:c3:99:aa
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8101 driverversion=1.025.00-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair
       resources: irq:27 ioport:2000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"thegreatbelow"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: 00:21:91:E5:CF:03   
          Bit Rate=6 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:954   Missed beacon:0
dmesg | grep wlan0
[   35.113583] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   35.120026] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   36.473871] wlan0: authenticate with 00:21:91:e5:cf:03
[   36.485339] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[   36.491147] wlan0: authenticated
[   36.493798] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[   36.497267] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[   36.503385] wlan0: associated
[   36.503417] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   39.514131] wlan0: deauthenticating from 00:21:91:e5:cf:03 by local choice (reason=2)
[   39.535604] wlan0: authenticate with 00:21:91:e5:cf:03
[   39.545755] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[   39.548952] wlan0: authenticated
[   39.550071] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[   39.553836] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[   39.558780] wlan0: associated
[   39.565815] wlan0: deauthenticated from 00:21:91:e5:cf:03 (Reason: 9)
[   43.031072] wlan0: authenticate with 00:21:91:e5:cf:03
[   43.042810] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[   43.045973] wlan0: authenticated
[   43.046253] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[   43.049718] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[   43.053067] wlan0: associated
[  152.697155] wlan0: deauthenticated from 00:21:91:e5:cf:03 (Reason: 6)
[  152.760546] wlan0: authenticate with 00:21:91:e5:cf:03
[  152.770479] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[  152.772431] wlan0: authenticated
[  152.775826] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[  152.779294] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[  152.781909] wlan0: associated
[  567.270184] wlan0: deauthenticated from 00:21:91:e5:cf:03 (Reason: 4)
[  582.703100] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  590.271543] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  590.928532] wlan0: authenticate with 00:21:91:e5:cf:03
[  590.938915] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[  590.941465] wlan0: authenticated
[  590.942559] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[  590.945860] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[  590.948246] wlan0: associated
[  590.948268] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1538.574032] wlan0: deauthenticated from 00:21:91:e5:cf:03 (Reason: 4)
[ 1538.628557] wlan0: authenticate with 00:21:91:e5:cf:03
[ 1538.638325] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[ 1538.640723] wlan0: authenticated
[ 1538.644710] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[ 1538.648201] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[ 1538.650911] wlan0: associated
[ 1807.559500] wlan0: deauthenticated from 00:21:91:e5:cf:03 (Reason: 4)
[ 1822.644903] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1829.968446] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1831.186853] wlan0: authenticate with 00:21:91:e5:cf:03
[ 1831.198140] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[ 1831.200591] wlan0: authenticated
[ 1831.201847] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[ 1831.206106] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[ 1831.208359] wlan0: associated
[ 1831.208384] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1831.216023] wlan0: deauthenticating from 00:21:91:e5:cf:03 by local choice (reason=2)
[ 1831.226783] wlan0: authenticate with 00:21:91:e5:cf:03
[ 1831.232283] wlan0: send auth to 00:21:91:e5:cf:03 (try 1/3)
[ 1831.263123] wlan0: authenticated
[ 1831.265844] wlan0: associate with 00:21:91:e5:cf:03 (try 1/3)
[ 1831.271737] wlan0: RX AssocResp from 00:21:91:e5:cf:03 (capab=0x431 status=0 aid=4)
[ 1831.273446] wlan0: associated

closed as off-topic by Braiam, chaskes, Rinzwind, Mitch Apr 30 '14 at 7:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, chaskes, Rinzwind, Mitch
If this question can be reworded to fit the rules in the help center, please edit the question.

  • try this, if work write a /etc/pm/sleep.d/wifi file killall -9 wpa_supplicant rmmod iwldvm rmmod iwlwifi modprobe iwlwifi – user273507 Apr 24 '14 at 8:36
  • I am having the same problem as you are describing. I've had similar problems using 13.10 but I was able to solve them using the advice given here. However, after doing a clean install of 14.04, disabling 11n for iwlwifi doesn't help. Maybe it works for you, though. – Ham Vocke Apr 25 '14 at 11:19
  • I had the very same problem on a Dell Vostro V131 notebook. The 802.11n mode in the wifi driver is buggy and has to be disabled. The hints here did the trick: ubuntuforums.org/showthread.php?t=2219014 – user274943 Apr 27 '14 at 12:42
  • @Braiam This question appears to be about Ubuntu 14.04, which is not a development version? – bain May 15 '14 at 13:50
  • @bain worked before + not working now = bug. – Braiam May 15 '14 at 13:56

Browse other questions tagged or ask your own question.