14

I've been struggling now for hours to setup my Bluetooth Audio connection to Bose Soundlink Mini. I can add the device and pair it but when I try to connect via GUI it always disconnects automatically. Sometimes this last a couple of seconds but mostly only 1-2 seconds. Sometimes I can hear a little beep on the audio device which normally indicates that a device is connected.

I already tried to install Blueman but I get the same problems. I also tried to connect via command line but I cannot even detect the device with hcitool scan (although he finds the device with the GUI).

I also reinstalled bluez and installed every possible package containing the name bluez in it because i thought it might be a missing package...but no success.

I'm now under Ubuntu 14.04 but I had the same trouble back with 13.04 and 13.10 although I got it working back then sometimes (but mostly the same issue).

Any help on how to proceed/debug etc. would be appreciated!

5
+100

First, make sure that pulseaudio-module-bluetooth and any/all relevent bluez audio packages are installed, then you may try the suggestions found here see if that helps. Once you get them connected you will likely want to check the audio profile in Blueman and the pulse audio mixer and be sure it is set to "High Fidelity Playback (A2DP)" and not "Telephony Duplex (HSP/HFP)" or they will sound horrible.

  • I did as you said. but sadly the same problem. Bleutooth keeps on connecting and disconnecting again.saidly my VPN now has the same bug... I don't know if it has the same reason... – Joschi May 4 '14 at 16:29
  • 1
    worked now after deinstalling blueman... i have no clue why. – Joschi May 4 '14 at 17:15
3

Shamelessly cribbed from that blog post above, but this is what worked for me on 14.04.

sudo apt-get install pulseaudio-module-bluetooth
sudo pactl load-module module-bluetooth-discover

Then open up your bluetooth manager (aka blueman), pair the device, set it to the a2dp audio profile, then start playing some audio. Open up the pulseaudio volume control and you should be able to change to the device using the output devices tab.

  • 9
    I get "Failure: Module initialization failed" after issuing the second command. I'm on Debian testing so I guess I have to solve the module issue first. Using the same hardware (BOSE SoundLink Mini) – jeremiah Feb 13 '16 at 11:27
  • @jeremiah - did you find a solution to the error that you were getting? – kapad Apr 21 '16 at 17:18
  • @kapad -- no I did not. But I haven't worked on it much either. – jeremiah Apr 21 '16 at 18:16
1

I did a mix of things. I couldn't comment because my rep is too low. But I followed this: https://erikdubois.be/installing-bose-quietcomfort-35-linux-mint-18/ and this stackexchange thread.

1 )in /etc/bluetoothaudio.conf

"Copy/paste these lines inside. Do not change anything. The order is important."

[General]

Disable=Socket
Disable=Headset
Enable=Media,Source,Sink,Gateway
AutoConnect=true
load-module module-switch-on-connect

2) In the terminal:

If you don't have blueman installed:

sudo apt-get install blueman

Then:

sudo apt-get install pulseaudio-module-bluetooth
sudo pactl load-module module-bluetooth-discover

3) "Then open up your bluetooth manager (aka blueman), pair the device, set it to the a2dp audio profile."

Update: Turns out that I have to run every time I want to reconnect:

sudo pactl load-module module-bluetooth-discover
0

For Ubuntu >= 16.04

sudo apt-get install bluetooth pulseaudio-module-bluetooth

then reboot

Solution from here: PulseAudio can not load bluetooth module 15.10/16.04/16.10

That's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.