I have an Ubuntu 14.04 server that has no external monitor connected. I use NoMachine to remote control the machine. When I do so, the Unity/Gnome interface doesn't see any monitors connected, so I can only use 800x600 when connecting with NoMachine. If I plug in a monitor, I can set the resolution to whatever size the NoMachine window is on the remote computer.

Is there a way to create a "fake" monitor device on Ubuntu so I can set a desktop resolution in Unity/Gnome?


Found a way to do it without requiring a dummy plug: Ubuntu Headless VNC VESA 800x600 Resolution Fix ~ Andy Hawkins @ June 12, 2011

Basically install a dummy driver:

sudo apt-get install xserver-xorg-video-dummy

Then write it in the /usr/share/X11/xorg.conf.d/xorg.conf (or possibly /etc/X11/xorg.conf) file (create one, if it does not exist):

Section "Device"
    Identifier  "Configured Video Device"
    Driver      "dummy"

Section "Monitor"
    Identifier  "Configured Monitor"
    HorizSync 31.5-48.5
    VertRefresh 50-70

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "1024x800"

Then restart the computer.

| improve this answer | |
  • 3
    Please edit the answer, the package is being updated. Try sudo apt-cache search video-dummy. – cctan Aug 12 '15 at 9:56
  • 1
    Creating the file /usr/share/X11/xorg.conf.d/xorg.conf with this content, or the one from xpra.org/xorg.conf, my Ubuntu does not boot anymore (it gets stuck with the Ubuntu logo screen before the login screen). What can be the problem? – David Portabella Aug 23 '16 at 21:40
  • 2
    Link in the answer appears to be broken. – rsethc Aug 12 '17 at 9:15
  • 12
    Also broke my os. Did not boot. Its remote and now I need to get in a car and drive 1hr. Risky stuff :-) – Derek Apr 7 '18 at 17:49
  • 2
    This should no longer be accepted solution. It's bricking too many OS's for people. including mine :) – Darius Dec 30 '19 at 10:38

Specify the resolution on a Ubuntu 14.04 desktop without a monitor connected:

From the xrandr man page:

--fb widthxheight
   Reconfigures the screen to the specified size. All configured 
   monitors must fit within this size. When this option is not 
   provided, xrandr computes the smallest screen size that will 
   hold the set of configured outputs; this option provides a 
   way to override that behaviour.

Therefore use the command after connecting:

xrandr --fb 1280x1024
| improve this answer | |
  • Cool, it's work! – burtsevyg Sep 26 '16 at 10:02
  • 3
    For me it say's: Can't open display – ar2015 Jun 2 '17 at 7:05
  • 3
    @ar2015 Run the command as xrandr --fb 1280x1024 -display :0 – Terrance Oct 29 '17 at 23:45
  • @Terrance I am getting No protocol specified Can't open display :0 – Rufus Jan 22 '19 at 6:57
  • @Woofas Are you logged in to the system in Wayland? As far as I know, xrandr only works with X.Org. I just ran my command on an 18.04 system again and it works fine, but I am using Xubuntu which is defaulted to X.Org. – Terrance Jan 22 '19 at 14:25

This is a hardware solution/workarround which may work for some graphics hardware/driver.

  • Either you buy a Dummy VGA (or DVI analog) plug or some calling it Dummy Dongle.

  • Or just use 3 resistors of around 75 Ohm at the VGA output: 1→6, 2→7, 3→8.

    +/- 10 Ohm may work without any problem. Some cards work with just one resistor. (Like my Intel, 2→7 or 3→8, will detected as a monitor)

Reference: How to create dummy plugs for your graphics cards.

| improve this answer | |
  • 1
    Sounds like an interesting idea. I'll give it a shot. – John Chapman Apr 27 '14 at 19:10
  • 2
    Honestly, this is the simplest way to go. There are plenty of tutorials out there for workarounds, but this just plain works and will save you a lot of time. The DIY option seems solid, but dummy plugs on Amazon are $20. Just make sure you get a good one to support your resolution. – Jason Capriotti Feb 22 '17 at 21:19

Consider Xvfb which is probably least likely to mess up the display when you actually plug in a real monitor

The following commands will start lightdm on a fake display with ID 1 and resolution 1024x76

export DISPLAY=:1
Xvfb :1 -screen 0 1024x768x16 &
sleep 1

#exec gnome-session & # use gnome-session instead of lightdm
exec lightdm-session &
| improve this answer | |
  • 1
    Thanks, this helped me to run chrome on Debian without display. – DedaDev Nov 2 '19 at 12:37
  • Thanks, with this I was able to start a xfreerdp client open a rpd session at boot without user interaction (in order to start a X program at startup) – Jako Sep 25 at 6:16

I'm on Ubuntu 18.04, this is how I solved it:

I've created the virtual display using the answer to this question: https://unix.stackexchange.com/questions/378373/add-virtual-output-to-xorg

Create a 20-intel.conf file:

sudo vi /usr/share/X11/xorg.conf.d/20-intel.conf

Add the following configuration information into the file:

Section "Device"
    Identifier "intelgpu0"
    Driver "intel"
    Option "VirtualHeads" "2"

This tells the Intel GPU to create 2 virtual displays. You can change the number of VirtualHeads to your needs.

Then I made a shell script (don't forget to set executable) and put that in Startup Applications:

#! /bin/bash

/usr/bin/xrandr -d :0 --output VIRTUAL1 --primary --auto
/usr/bin/xrandr --newmode "1600x900_60.00" 118.25 1600 1696 1856 2112 900$
/usr/bin/xrandr --addmode VIRTUAL1 "1600x900_60.00"

That way, VIRTUAL1 is set as output and connected. At boot, a new mode (found using "cvt 1600 900") is being created and appointed to VIRTUAL1.

Only issue with this is: dock is missing at reboot... Haven't solved that yet.

| improve this answer | |

For me no one of the above solution works. To add a new device/screen VIRTUAL1, what has worked for me is :

  • Install the packet xserver-xorg-video-dummy
  • Update xorg.conf

All details are here : Add Fake Display when No Monitor is Plugged In

Info : for me, it works in editing /etc/X11/xorg.conf instead of /usr/share/X11/xorg.conf.d/xorg.conf

| improve this answer | |
  • Tested with Ubuntu 20.04LTS and TeamViewer and its working fine! /etc/X11/xorg.conf path worked for me too. – BirdOfPrey Aug 16 at 20:38
  • THis worked great for me but how do I get a regular screen back when I connect a monitor? – Jeff Barnett Sep 15 at 2:06
  • 1
    Did you linked this page in this page? Or I am wrong? – AK 12 Sep 15 at 9:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.