Short summary: 14.04 is much slower than 12.04 even with more RAM assigned.

I'm using latest VirtualBox 4.3.10 on Mavericks 10.9.2. How can I make it faster?

  • Or try enabling hardware visualisation in BIOS xD – Dusan Milosevic Apr 22 '14 at 19:10
  • windows? don't understand what you mean... but I already found a solution (below) – davidhq Apr 22 '14 at 19:59
  • I'm kidding :D .. – Dusan Milosevic Apr 22 '14 at 20:17
  • 1
    ok :) now I actually understand the sentence... before I though it was serious and it didn't make sense... but to disappoint you I'm actually running a VM on something even better than Ubuntu... but I agree with you - if I had Windows as a main system, it would make sense to move it to VM ^_^ – davidhq Apr 22 '14 at 21:27
  • I have the same problem but on Hyper-V 2012 R2. Any idea? – user275815 Apr 29 '14 at 11:43
up vote 76 down vote accepted

Enable 3D acceleration from virtual machine setting worked! I haven't tried that because in 12.04 I didn't have that selected so I thought it should work without it.

enter image description here

  • 3
    After enabling 3D acceleration and restarting, my Ubuntu display was only 640x480 and an error like "Could not apply stored configuration for monitors" was shown. This went away after installing the VirtualBox Guest Additions and since then it seems to be working fine, just as 12.04 did. – FriendFX Jun 23 '14 at 0:03
  • 3
    Sorry but WHERE did you enable 3D acceleration? In Windows? In BIOS? In Ubuntu? In Oracle Virtual Box? – Dims Jul 7 '14 at 18:27
  • 7
    In Virtual Box! – davidhq Jul 11 '14 at 17:48
  • 2
    I'd like to note, that in my particular case, I had a slow UI on a set up with 3D acceleration on, and turning it off was what sped it up, so if you already have this on and you're having a slow UI, try turning it off. – Goose Mar 22 '16 at 12:10
  • 2
    I dont think it made any difference to me. – prayagupd Sep 22 '16 at 17:48

Also, I found the following helped for me. Enable the use of the Host IO cache for the SATA controller for the virtual disk.

  • Be careful here. In my situation enabiling Host I/O Cache decreased performance. – Cezary Daniel Nowak Jun 9 '15 at 15:12
  • @CezaryDanielNowak: true the same with me, It was enabled by default. But disabling it actually improved the performance. – Indigo Mar 6 '16 at 13:35

Watch out for the "Execution Cap" setting under the processor setting for the virtual machine. I stumbled upon a user having it set to 1% when it normally should be at 100%.

You can find it under 'System'->'Processor'->'Execution Cap'. It's a slider.

enter image description here

Sorry for my ugly theme.

Run Oracle VB Select your VM on the LHS Settings -> Display - > Video tab, "Enable Features:" and check the Enable 3D Acceleration box Click OK

Disabling the background blur of the search panel with the Unity Tweak tool also improves the speed of the Ubuntu UI.

I have Variety installed from the PPA's and discovered it was slowing VirtualBox to a crawl at times. Disabling the autostart from both the Variety preferences and Startup Applications restored the speed.

  • How do check if I have Variety installed? I don't think I have it installed. It doesn't show up when I type in "variety" in the search box. If it is installed how would Disable it? – Yonatan Simson Jun 14 '16 at 9:05
  • It's not in the main distribution but a PPA. Peter Levi: the maintainer will show you how to install it from this link. peterlevi.com/variety/how-to-install – Christopher Jun 15 '16 at 11:59

protected by Community Oct 19 '14 at 16:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.