2

I just upgraded to Ubuntu 14.04, and getting a bug where I can't move files to the trash. When I go to delete something it says file "can't be put in the trash. Do you want to delete it immediately?" I tried the instructions here: Can't move files to the trash but it didn't work. Not sure why this happened with the upgrade. Any help much appreciated!

closed as off-topic by Radu Rădeanu, Braiam, Alvar, Avinash Raj, Eric Carvalho Apr 29 '14 at 22:40

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, Alvar, Avinash Raj
If this question can be reworded to fit the rules in the help center, please edit the question.

4

The OP posted:

Solution:

sudo nautilus

Go into .local/share and delete the Trash folder. Make a new folder and name it Trash, then go into terminal and do this:

cd ~/.local/share
sudo chown username:username Trash

where username is your own username.

I have no idea why it doesn't work unless you remake the trash folder, but this way worked for me. Good luck if anyone else gets this bug!

  • @bobleponge314 Your answer is still to similar with one from the duplicate question: this one. – Radu Rădeanu Apr 22 '14 at 19:30
  • Should I be bothered by the fact that I was able to remove and recreate the folder "Trash" without sudo? – Nearoo Oct 24 '16 at 16:20
  • @Nearoo That's ok, ~/.local/share is in your home directory and owned by you,. – Volker Siegel Apr 25 '17 at 8:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.