19

I've installed Ubuntu 64bit on Virtualbox 4.2.16. Guest Additions were installed in Ubuntu as well.

However the display resolution of Ubuntu does not seem to change as the Virtualbox window is resized or if we were to go into Full Screen mode. Any ideas?

9

Install the latest version of virtualbox say 4.3.10 or above from here and also it's corresponding guest additions, extensions Or you can also install the latest virtualbox version from the multiverse repository via apt-get. I also faced the same problem in older virtualbox version running Ubuntu 14.04 as guest OS.

To install guest additions, follow this answer.

12

I had this problem as well running a newly installed version of VirtualBox (VirtualBox 6.0). I tried installing the aforementioned packages but had no luck. My solution was simpler than I had anticipated. While the machine is powered off, go to:

Settings (of the VM) > Display > Graphics Controller > and select "VBoxVGA"

VirtualBox had set this option to "VMSVGA" by default for me. Fortunately, I noticed this subtle difference when comparing the settings between some of my virtual machines. I hope this works for you as well!

  • This worked for me, too, but graphics performance went WAY down with VBoxVGA. Noticeable typing lag. I put it back to VMSVGA and increased the graphics memory and I believe this helped me to get larger desktops with the better performance. – Bogatyr Sep 2 at 1:16
9

just type: sudo apt-get install virtualbox-guest-additions-iso

  • THIS did the trick. – Yar May 26 '16 at 13:15
  • This did the trick for me! Worked out of the box with ubuntu, but not with lubuntu. I previously ran the GuestAdditions CD image under the devices menu but that did not work. I also tried to install virtualbox-guest-dkms and dkms and none worked. – Julian Cienfuegos Feb 28 '17 at 16:14
6

If that happens once you have the guest additions installed, it may help reconfiguring DKMS

dpkg-reconfigure virtualbox-guest-dkms

It happens to me every time Kernel is upgraded and the above provides the solution.

  • 3
    Don't forget to install the dkms package too. It's not a dependency, but if you have it installed, kernel upgrade hooks will rebuild the Virtualbox kernel modules automatically. – gertvdijk Dec 4 '14 at 13:56
5

For those who already have the guest extensions and additions , you should go check for additional drivers and install the proprietary video driver for virtualbox , then reset your machine

1

I have installed and removed Guest Additions multible times (either from 'Devices' menu or from terminal) with no luck. I have noticed that while doing this, i was getting some terminal messages regarding DKMS.

So... i tried to install DKMS separetely and boom! Full screen with high resolution again! So to summarise:

  • Install Guest Additions (Devices->Insert Guest Additions CD image...)
  • Open a terminal and type this sudo apt-get install virtualbox-guest-dkms
  • Restart

Hope it helps.

1

I tried all of the suggested solutions:

  1. In the guest machine (Kubuntu 18.04), I installed 'virtualbox-guest-additions-iso' (thanks to Moshe Beeri)
  2. Installed 'virtualbox-guest-dkms' (thanks to Dr. Windows for the hint)
  3. While the guest machine is turned off, I checked if 'Maximum Guest Screen Size' is set to 'Automatic' (saw this suggestion in another post)
  4. Then I changed the 'Graphics Controller' to 'VBoxVGA'. (thanks to uceieluez)

Only after the 4th step the resolution of the guest machine has been fixed. Now it automatically resize to fit the virtual machine window.

I am not sure if the fix was because of changing the graphics controller or all of the above. Anyway, thank you all.

  • For future readers, I would suggest selecting VBoxSVGA; ie make sure there is an 's', although I haven't tried it without. – Robert Lugg Oct 11 at 22:10
0

In addition to ensuring that guest additions is actually installed in the guest machine you should also check the 'Auto-Resize Guest Display' option in the 'View' menu in Virtuablbox (on the host machine).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.