130

I have run following command accidentally

sudo chown [username] -hR /

Now sudo su getting error:

sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set

How to Solve This?

7
  • Note: When I had this issue, I had reinstalled the OS (Because at that time on-other answers exist and I can't wait more). So, Now new answers will be no longer supported from my side!
    – Pandya
    Commented Jan 30, 2015 at 12:18
  • Thanks to the tiny Warning posted under Option 1 here which I gladly ignored and ended up here! Commented Jun 30, 2017 at 9:35
  • 1
    Use medium.com/@KongToonArmy/… by KongToonArmy KongToonArmy
    – Rupsingh
    Commented Aug 20, 2019 at 8:08
  • I wanted to answer this, its closed now, and IDK why. Its the oldest post I can find pertaining to this specific error message. Its important to note, that sometimes you can get this error message by adding 2 or more administrators to a single system. Another thing that can happen is that you could have change the permission of your binaries. In both of these situations, you could recieve this error message. Its important to note, that this error message comes the fundamental fsys, and not from distro specific software. From my understanding, this error is basically saying that
    – JΛYDΞV
    Commented Mar 1, 2022 at 7:04
  • 1
    I just changed permissions for the other account, restarted the computer and everything worked.
    – JΛYDΞV
    Commented Mar 1, 2022 at 7:26

12 Answers 12

218

As you'll read on this answer on SO, this problem is not as hard as people are making it. You can get the sudo command working again without a reinstall by following these simple steps:

  1. Log out as the current user, then log back in as root.
  2. Execute chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
  3. Log out as root, then log back in as the current user.

This does the trick and is much quicker and less painful than the "nuclear option" recommended in other answers.

If your root password is not set, you can boot in Recovery Mode to set it.

Note that this will resolve the titular error /usr/bin/sudo must be owned by uid 0 and have the setuid bit set but if like the OP you did more than mess up the permissions of the /usr/bin/sudo file, a more "nuclear" option may in fact make more sense.

12
  • 25
    If you do not have a root user, restart and press Esc to enter the grub menu. There select Advanced options for Ubuntu and select recovery mode. Then select root and you can find yourself in the root shell. If you get an error that the filesystem is in read only mode, do: mount -o remount,rw /
    – George
    Commented Oct 23, 2014 at 2:25
  • 22
    Sure, that will fix sudo, but it isn't going to fix the dozens of other things that were broken.
    – psusi
    Commented Jan 30, 2015 at 20:57
  • 7
    Had same problem in my lxc container, additionally had to do this: chown root:root /usr/lib/sudo/sudoers.so && chmod 4755 /usr/lib/sudo/sudoers.so; chown root:root /etc/sudoers; chown root:root /etc/sudoers; Commented Jul 12, 2016 at 5:40
  • 7
    using su root instead of sudo su, followed by the root password can save you some headache, if your ssh, or instead of going to grub. Commented Aug 19, 2016 at 1:03
  • 5
    in addition to what @infro said I also needed chown for /etc/sudoers.d, /etc/sudoers.d/README and /var/lib/sudo Commented Sep 14, 2016 at 8:59
51

Back up your data and reinstall.

If this looks extreme, that's because it is. This isn't just sudo. You destroyed the permissions structure across your entire filesystem. Some of the other answers can get sudo working, but ignoring the whole problem is inviting a later disaster.

You could try to mirror the owners off another install but there are cases (/var/ for example) that are highly dependant on what you've actually got installed. If you want to get a scale of the problem, I've actually had a crack at helping somebody fix this sort of issue before. The fix is manual, long and could easily leave your system insecure or broken.

Picking through that mess is going to take considerably longer than a clean install.


This has had a couple of drive-bys from folks that don't understand the seriousness of the situation here. To them it looks like a big pile of unnecessary work, the sort of thing a rogue plumber or mechanic says to shake you down for a bigger job.

If you've only changed the permissions on /usr/bin/sudo, by all means, just fix that. But this question is about a total system change. Every file (save the runtime-only ones) are now owned by the user. Everything the user runs (eg browsers, browser exploits) could then overwrite system files, spy on you, extract any data. This needs to be corrected. Per above, this is difficult. The easiest way is a reinstall.

So please, don't be lazy about this. Filesystem permissions help keep you safe, don't mess with them.

14
  • 12
    This should not be the accepted answer. Boot into recovery mode and run the commands in the following answer: askubuntu.com/a/471503/311767
    – Tisch
    Commented Jun 8, 2017 at 9:35
  • 10
    @Tisch That answer fixes sudo. The question assumes the entire system is owned by $USER. Just repairing sudo leaves the rest of the system in a very vulnerable state. A reinstall is justified unless you want to spend hours trawling a working system to compare who system files should be owned by.
    – Oli
    Commented Jun 8, 2017 at 14:38
  • 11
    @oidualc Because it's the right answer. I'd already covered this in a previous comment and I've just added an edit. Filesystem permissions are a serious security feature. Don't be lazy about fixing this. To finish your analogy, your toe has gangrene and it's given you septicemia. You cannot see that in your delirious state, but trust me, I'm a doctor.
    – Oli
    Commented Nov 20, 2017 at 20:34
  • 4
    @oidualc You're welcome to disagree but it doesn't mean you're not still confusing a single symptom with a systemic problem.
    – Oli
    Commented Nov 21, 2017 at 10:32
  • 4
    @PeterDrinnan The answer involving nuclear ordinance assumes a global chowning. Your case sounds much more discrete. That said, why on earth do you have a sudo binary in /usr/local/bin/? That seems very dodgy to me.
    – Oli
    Commented Apr 26, 2019 at 12:38
21
  1. go to recovery mode by keep pressing Esc while booting the system.

  2. select root option in long list you can see after entering into recovery mode (it is actually root shell)

  3. type command - mount -o remount / (Or in recovery you can click on grub option. This helped me get read-write permissions on the file system. This basically updated the read/write mode on the file system since the command wasn't working for me initially)

    It will remount your file system in read and write mode.

  4. command - chown -R root:root /usr this command will change ownership from "user" to root again recursively

  5. now still i had problem with sudo command, so I again followed step 1,2,3 and executed chmod 4755 /usr/bin/sudo

Now I really think that re-installing would have been really a "nuclear option"

1
  • 1
    @Hridaynath you're missing the / in usr/bin/sudo on #5 in your answer
    – mdo123
    Commented Feb 13, 2019 at 21:52
10

Had the same issue on my droplet on digital ocean.

sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set. Below are command that ive execute and reboot after.

chown -R root:root /usr/bin/sudo
chmod -R a=rx,u+ws /usr/bin/sudo
chown -R root:root /usr/lib/sudo/sudoer.so
chmod -R a=rx,u+ws /usr/lib/sudo/sudoer.so

Hope it helps.

3
  • 1
    You don't need -R here. How did you manage to get permission to chown and chmod the files?
    – Zanna
    Commented Sep 27, 2016 at 5:02
  • without -R should be working..execute the command on my droplet console. Commented Sep 27, 2016 at 7:27
  • @Zanna Digital Ocean images have root login enabled by default.
    – wjandrea
    Commented May 9, 2018 at 15:37
4

The above methods didn't work for me, because I couldn't "log back in as root" (unknown password) But I got a root shell by editing

vi /etc/lightdm/lightdm.conf

autologin-user=root
greeter-show-manual-login=true

After rebooting I was finally able to run

chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
1
  • 2
    The "log in as root" originally said was actually "Reboot into recovery mode and pick the root shell". But as other comments have said, this only rescues the sudo. There are dozens and dozens of files that need the correct security which you have to manually fix. A reinstall is both quicker and more likely to fix everything.
    – Oli
    Commented Jul 14, 2015 at 8:14
3

Unfortunately, if you do not have a full backup, probably the best thing you can do at this point is to reinstall.

Consider that you have changed all the files ownership to the same user, completely messing the security paradigm of your system....

If you search this site there are a lot of similar problems with chmod, as for example How can I recover from chmod -R a-wrx / command?

2

I was not able to edit lightdm.conf file under running system. I fixed things like this:

  1. boot Ubuntu live usb
  2. mount the root partition in order to access /etc/lightdm/lightdm.conf on the installation
  3. sudo -H gedit /mnt/etc/lightdm/lightdm.conf and add the following lines from Anno2001's answer

    autologin-user=root
    greeter-show-manual-login=true
    
  4. reboot

  5. run command:

    chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
    
  6. Change back default user in /etc/lightdm/lightdm.conf (you don't want to autologin as root every time, which would be very insecure and dangerous)

  7. reboot, and my system works fine again.
1

If you have root user password then:

  1. Login as root user

  2. open terminal

  3. Enter following commands:

    mount -o remount /
    chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
    chown root:root /usr/lib/sudo/sudoers.so && chmod 4755/usr/lib/sudo/sudoers.so
    chown root:root /var/* && chmod 4755 /var/*
    

If you do not have root user password then:

  1. Reboot your system in recovery mode(boot and press and hold esc button to enter in recovery mode)

    here it looks like

  2. Navigate to (advance option for linux) by using down arrow button and press two times Enter

    here it looks like

  3. Navigate to root by using down arrow button and press Enter

    here it looks like

  4. Now enter following commands:

    mount -o remount /
    chown root:root /usr/bin/sudo && chmod 4755 /usr/bin/sudo
    chown root:root /usr/lib/sudo/sudoers.so && chmod 4755/usr/lib/sudo/sudoers.so
    chown root:root /var/* && chmod 4755 /var/*
    
  5. Press ctrl+d and then select resume option to boot normal

2
  • I'm using PopOS, so a USB disk reboot, I just corrected the permission for sudo file 4755 and all good because I knew that was the only thing I messed up. Commented May 15, 2023 at 18:15
  • @DanielKatz Good to know that. Commented May 9 at 13:40
0

You destroyed the permission structure of your entire filesystem - YES IT's TRUE.Entire root is corrupted. But don't panic recovery is quite simple.Create a new volume of the root disk with the latest snapshot then dettach the old volume and attach it to the instance with the same disk name.With 5 minutes downtime you can login to the server again.

1
  • 1
    This answer needs way more details and some step by step instructions.
    – David
    Commented Sep 28, 2022 at 14:49
0

This applies to those environments where they have docker / Kubernetes environment running and has host root file system is mounted into the container / pod.

kubectl exec -it mypod -- chown root:root /host/usr/bin/sudo && chmod 4755 /host//usr/bin/sudo

I have not tried creating a fresh Kubernetes pod but I guess that should work too.

0

For those who does not have the root password, but who do have docker installed, here is a one-liner:

docker run -v /:/target bash bash -c "chown root:root /target/usr/bin/sudo && chmod 4755 /target/usr/bin/sudo"

Since the docker image run as root, you are root in the image. The volume mounted allow you to change your root structure. The command allow you to fix your sudo.

PS: imagine what else you could don without root permission and a docker...

-2

I have changed /usr/lib/ to root owner but but sudo only executes with root login in the terminal.

step one: su root step two: cd /usr/lib step three: chown -R root:root sudo

and that is it. Just NOTE you have tu run su root every time you want to use sudo.

1
  • 2
    except Ubuntu has disabled root access by default so you can't su root
    – Zanna
    Commented Jan 2, 2017 at 8:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .