I have a rather serious shutdown/reboot issue with my Ubuntu OS on my brand new Dell latitude E7440 netbook. The issue does not seem to depend on the OS version: it occurs with 12.04, 13.10 and now with 14.04. I've waited for the new LTS in the hope that it would solve my problem, but that is not the case.

After shutting down my ubuntu, my laptop reboots about two seconds after shutdown. I've tried many things to solve it, but none of them did the job. I have the 64 bit version of 14.04 installed and boot in legacy boot mode with secure boot disabled. The behavior is independent from a power cable/usb device/ethernet cable being plugged in. Strange enough, however, it does sometimes stay powered off after being used for several hours...

I know there have been several treats concerning shutdown/reboot issues, but none of them provides an answer to my specific case. I ran diagnostics in the BIOS to recover any potential hardware problems, but there were none. If you have an answer or even a clue on how to solve this issue, it will be highly appreciated! Thanks in advance!

  • Could some attached equipment be sending a wake signal?
    – fleamour
    Apr 22, 2014 at 10:51
  • Hi fleamour. The reboot also takes place without any cable/device/monitor connected, so that is not possible.
    – Kees
    Apr 22, 2014 at 11:06
  • In my case only happens when no power cable is connected.
    – lepe
    Nov 29, 2014 at 3:03
  • I just discovered that only when the bluetooth receiver (USB adapter) is connected (laptop running on battery) this problem happens.
    – lepe
    Dec 13, 2014 at 1:48
  • There seems to be a bug reported about this: bugs.launchpad.net/ubuntu/+source/linux/+bug/1346269
    – user457819
    Oct 5, 2015 at 11:58

6 Answers 6


I experienced exactly the same problem on my new computer Intel i5-4440 processor and Intel DB85FL motherboard (4th Gen). First I faced this problem with Ubuntu 13.10. and subsequently after upgrading to 14.04 LTS.

I did the following recently to solve this problem of SHUTDOWN and automatic REBOOT again withing a second or two.

I have Intel Visual BIOS. On power up I pressed F2 > POWER > Wake On LAN from S4/S5.

This has 3 options. 1. Stay Off, 2. Power on - Normal Boot, and 3. Power on - PXE Boot. My computer was set to #2, which was making it automatically REBOOT after SHUTDOWN. I now changed to #1 option mentioned above. Now it is okay.

Hope this would work for you as well. Best wishes.

  • bluepearlsky, thanks a lot! I would have never been able to fix this myself. Your fix did the job! I still consider it very weird that this is needed though... In my case (Dell latitude E7440, SSD, core i7) you need to go to 'power management' in the BIOS and there are 5 options for 'wake on LAN'. Like the answer above, you need to pick `disable' from those five.
    – Kees
    Apr 22, 2014 at 11:42
  • @Kees, if this answer solves your issue please take a minute and check the check mark under the vote count to the left, this will signify to everyone that your issue's been resolved.
    – terdon
    Apr 22, 2014 at 11:46
  • You are welcome, Kees. I am glad you could fix the problem. Have a nice time and take care. Apr 22, 2014 at 13:03
  • 1
    I have "wake on LAN" off so it doesn't solved it for me.
    – lepe
    Nov 29, 2014 at 3:05
  • 1
    I basically went into my BIOS and turned off every option with the word "wake" in it... I don't need my computer raising itself from the dead like some zombie. This was an HP zBook 15, just in case any other people are suffering with it... it turned on in my bag and overheated itself through a 90 minute drive... seems to be fixed now.
    – Adrian
    May 18, 2015 at 17:27

I also faced the same case on my Acer Aspire E1-470G using Ubuntu 14.04. These steps worked for me.

  1. Type in terminal

    sudo nano /etc/default/grub

    then find a line


    Modify it to

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off
  2. Type in terminal sudo nano /etc/grub/modules then add apm power_off=1 under line lp. Save and close the terminal.

  3. Update the GRUB

    sudo update-grub
  • 1
    No luck for me. In my system, there is no /etc/grub/ directory, and the "modules" file is in /etc/modules.
    – lepe
    Nov 29, 2014 at 3:04
  • I skipped step 2, but the problem was still resolved, thanks!
    – morloch
    Mar 23, 2015 at 5:59

I had the same problem with my new intel motherboard and core i5 processor, Ubuntu 14.04.1 64bit OS. I tried to disable wakeup from LAN from bios and did not get any success.

Then I modified



GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi=force apm=power_off

Still no success.

One of my colleagues suggested that, though mine was a desktop PC, I should install laptop-mode-tools, and surprisingly it worked!


Just had this problem with 14.04 on a Gigabyte GA-MA78GM-S2H based desktop. Tried all the BIOS settings I've seen suggested around the web with no luck.

Thought it might be a USB related wake. Used non USB mouse and keyboard and problem solved.

May not be a solution to laptop owners but thought i'd share the info on a few boards.


Disabling the wake on via LAN option is working well with my case.

Machine: HP Elitebook 850 G2 O/S: Ubuntu 14.04


Disabling "Wake on LAN" in the BIOS solves the reboot problem for my HP EliteBook 840 G2. (Ubuntu 15.04, Kernel: 3.19.0-21)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .