3

Based on this answer I used: sudo hdparm -W 0 /dev/sda to try and disable the write cache on my Ubuntu 13.10 box running on bare hardware. Additionally in /etc/hdparm.conf I also uncommented from the line #write_cache = off

When I run: hdparm -i /dev/sda i get:

...
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5 *udma6 
AdvancedPM=yes: unknown setting WriteCache=disabled
Drive conforms to: unknown:  ATA/ATAPI-3,4,5,6,7
...

Regardless, I still get these insanely high write through puts that are higher than my read which leads me to believe my write cache is still active. What is the correct way to disable the write cache on a Ubuntu 13.10 system??? i'm attaching a screenshot of a utility I've written that shows my write bw to be insanely high (2.2GB/s) until the write cache is filled up (looks like 1.2gb). Any feedback is greatly appreciated.

enter image description here

1 Answer 1

1

Disabling write caching will increase the number of writes to the system. As you can see in the link below

http://ubuntuhandbook.org/index.php/2014/01/disable-disk-caching-prevent-data-loss/

Write caching basically caches the data before the OS can write to the device, any then writes it together. It makes the system fast since you have less number of writes to the device, however it is risky since a power failure will result in the loss of the cached data.

You have turned off the write-cache hence all your writes are directly being written to the drive and thus you have high write througput.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.