33

Clean install of 14.04 LTS. Single OS. Have installed Chrome for linux, updated, removed, reinstalled 14.04 LTS. No flash. I have done everything from every site I can find, nothing. Using Chrome I get a Black Screen. (hardware acceleration is off)

Same with Chromium.....

Firefox attempts to update Flash player, then says I need to update my browser and flash to the newest version. (both are up to date).

Been 4 days and I am at my wits end......any help would be appreciated.

  • Chrome and chromium doesnt deliver flash anymore. you have to sudo apt-get install pepflashplugin-nonfree – Papachan Apr 22 '14 at 2:52
  • Yep. Did it. No Joy. There is a major bug with Flash player is 14.04 and no one is talking about it. – user271720 Apr 22 '14 at 3:02
  • weird. its working fine here. which gfx have you? – Papachan Apr 22 '14 at 3:03
  • working fine for me too, I think it's related to your hardware acceleration. – Mohammad_Hosseini Apr 23 '14 at 13:19
29

Update: the package pepperflashplugin-nonfree is now deprecated.

You need to install the adobe-flashplugin. Make sure to enable Canonical Partners software source before installing the package. It works for Firefox and Chromium

sudo apt-get install adobe-flashplugin

Read more about this on:

0

AFAIK If you use chromium, you indeed in need to install pepperflashplugin-nonfree, but in case of using Google Chrome for linux, it comes with pepperflash preinstalled. For example I got ver 34.0.1847.132 here with pepperflash ver.13.0.0.206 installed. To use it by default you need to go to chrome://plugins/ go to Adobe Flash Player section and select what ver. to use

0

There does seem to be a bug with Pepperflashplugin indeed. (Flashplugin-installer package would not work for Chrome too, only on Firefox)

As a workaround, I suggest using Chrome beta channel. (Currently version: 35.0.1916.69-1) First purge google-chrome-stable and also delete your Chrome config for starting clean.

sudo apt-get purge google-chrome-stable
rm -rf ~/.config/google-chrome
sudo apt-get install google-chrome-beta

This did the trick for me

protected by Community May 9 '14 at 14:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.