6

When I upgraded from 12 to 13 there were no problems. Going to 14.04 got the same message:

Nautilus Restart Required 

Dropbox requires Nautilus to be restarted to function properly.

(with a button to restart Nautilus)

When I clicked on the button this time there was no response. I am able to start it using the command from the Dropbox document:

~/.dropbox-dist/dropboxd

and everything seems good as far as syncing up the files in Dropbox. I can leave the terminal up while this is going but it should being doing this on it's own.

I do get the message on boot up that:

Authentication is needed to run '/usr/bin/dropbox' as the super user

I put in my password and nothing appears to happen. It appears that I should be doing something more.

Can anyone help me out with this?

  • Thanks - worked for me also. I had installed Ubuntu 14.04 and had the restart nautilus message but greyed out. Now all seem ok – user325091 Sep 9 '14 at 7:13
4

These commands will fix your problem:

sudo rm -rf /var/lib/dropbox/.dropbox-dist
dropbox start -i
| improve this answer | |
  • 3
    What do these commands do? If you could add a little more to it, that would be good. Any command that starts with "sudo rm -rf" needs a very good explanation. :) – Jo-Erlend Schinstad Apr 22 '14 at 21:19
  • 2
    It will remove the old Dropbox installation files and reinstall them. See bugs.debian.org/cgi-bin/bugreport.cgi?bug=734628 – slu May 10 '14 at 21:10
  • Doing "dropbox start -i" produces the following error: IOError: [Errno 13] Permission denied: '/var/lib/dropbox/.dropbox-dist/dropbox-lnx.x86_64-3.6.8/futures-2.1.3-py2.7.egg/EGG-INFO/top_level.txt' It worked when I did "sudo dropbox start -i" Done! – frepie Jul 12 '15 at 23:23
1

The executable file for Dropbox lies in the “/usr/bin” folder and it is pointing to the “/var/lib/dropbox” folder for its config files. Since the “/var/lib/dropbox’ folder is in the root directory, it will need superuser permission for Dropbox to be able to access it.

However, that is not the main cause of the problem. The main issue is that your config file should lie in your home folder (~/.dropbox-dist/), and it shouldn’t point to the “/var/lib/dropbox” folder.

  1. Open a terminal and type:

    which dropbox

  2. Open it with a text editor:

    sudo nano /usr/bin/dropbox

  3. Scroll down in the file until you find the lines:

    PARENT_DIR = os.path.expanduser("/var/lib/dropbox")

All we need to do is to change the filepath “/var/lib/dropbox” to “~”, so it becomes:

PARENT_DIR = os.path.expanduser("~")

This will direct Dropbox to access your Home folder for the config files.

  1. Restart Dropbox.

    dropbox start -i

Taken from here: http://www.maketecheasier.com/fixing-authentication-issue-dropbox-ubuntu/

| improve this answer | |
  • Doesn't work here - it still won't run without root permission. (MBA's solution doesn't work either). – digitig Jul 5 '15 at 20:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.