0

I upgraded to 12.10 in my quest to get to 14.04, but my computer (HP Pavilion dv 6c47cl) doesn't seem to like 12.10. It won't load to the gui, and so I am forced to go to the command line if I want to load ubuntu at all (and it still won't go to command line with startx).

I have tried upgrading from command line with the following commands:

1) sudo do-release-upgrade

(reports no new release found)

2) sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

(this will start trying, but will ultimately fail because it encountered an error while processing, was unable to open a file, or some other reason) Now whenever I run

sudo apt-get dist-upgrade

I get

dpkg: error processing /var/cache/apt/archives/xserver-common_2%3a1.13.3-0ubuntu6.2_all.deb (--unpack): trying to overwrite '/var/lib/xkb/README.compiled', which is also in package xserver-common-lts-raring 2:1.13.3-0ubuntu6~precise3

No apport report written because MaxReports is reached already

Errors were encountered while processing: /var/cache/apt/archives/xserver-common_2%3a1.13.3-0ubuntu6.2_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

Any advice on things I can try to make the upgrade happen?

1
  • try sudo do-release-upgrade -d – Panther Apr 21 '14 at 22:33
0

Try these commands,

sudo apt-get purge xserver-common-lts-raring
sudo apt-get -f install

Now run any of your commands like sudo apt-get upgrade or sudo apt-get dist-upgrade.

0

This is how I fixed the issue myself:

  1. sudo apt-get remove xserver-common-lts-raring
  2. If needed enter your password.
  3. When asked to remove type yes.

That should remove the file, and then you should have no more issues.

That worked the first time I tried it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.