2

I've been working on a personal project which involves parsing a binary stream of midi data from a controller. The way I had been doing it was reading from /dev/dmmidi1. Over the weekend I upgraded from Kubuntu 12.04 to Kubuntu 14.04. Now, when I plug in my midi controller, there are no device files that look like ones that would correspond to my controller.

When I run aplaymidi -l, the output shows the device that I expect. Why am I not seeing device files?

2

The /dev/*midi* files are for the OSS interface, which is considered legacy. Apparently, CONFIG_SND_OSSEMUL is not enabled in your kernel.

You are supposed to use the ALSA library for receiving MIDI data, but you could just read from /dev/snd/midi*-

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.