4

This question already has an answer here:

I updated from ubuntu 13.10 to 14.04. I have a quad core, and one core is pegged at 100% usage because of kworker.

I know that kworker generally is doing things on behalf of the kernel, but I don't know how to determine what the issue is. Any help would be greatly appreciated.

marked as duplicate by Eric Carvalho, karel, Evandro Silva, Elder Geek, Charles Green Jan 23 '15 at 15:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Are you running any processor-intensive process? Is a restart of the system possible? – jobin Apr 21 '14 at 18:17
  • Also impacting me - I have a quad core and two of the cores are at 100% both with kworker, following an upgrade from 13.10. Looks to me to be an issue with 14.04. – user272872 Apr 23 '14 at 6:10
  • Did you select encryption when you installed ubuntu 14? I just had the same issue when I did this and shared one of the encrypted drive's folders through NFS and mounted it on a Virtualbox instance on the same machine. The solution for me was to share files via SSHFS instead. – Programster Apr 23 '14 at 8:20
  • 2
    I did not add encryption, and it looks like if I disable the NFS-kernel-Server it goes away. When I start it up again, it comes back to taking one of my cores. – user272085 May 9 '14 at 16:56
  • 2
    Just to let you guys know that I had the same issue and disabling nfs-kernel-server helped, but it was not a permanent option. I had Ubuntu 12.04 Server as my VM and Ubuntu 14.04 as my host. After upgrading my VM (ubuntu 12.04 server) to the latest patches using sudo apt-get upgrade, the problem disappeared. There must have been some fix -- not sure. – Dilshod Tadjibaev Jun 6 '14 at 20:47
0

htop can help diagnose more accurately what's going on with your system.

sudo apt-get install htop
htop

Use the htop command in an open terminal when you experience the issue to determine what the issue is.

  • In my case, when I disable the nfs-kernel-server, my issue is resoled. How is the screen locking relate, or is my issue a separate issue? – user272085 May 12 '14 at 2:16
  • Maybe unrelated; using htop during the problem is how to determined what the issue is. – mchid May 17 '14 at 15:28
  • Screenlock can be an kworker issue if you Reboot the system and the problem goes away or Disable lock screen under System Settings > Brightness & Lock so this does not happen. – mchid May 17 '14 at 15:37
  • Another issue occurs when somehow the permissions get screwed up. The fix is to sudo chown -R mchid:mchid /home/mchid replacing mchid with your username. – mchid May 17 '14 at 15:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.