8

In my fresh install of Kubuntu 14.04, I can't use anymore the (pretty useful) shortcut to move along words: (right) CTRL + Left (or Right) Arrow.

The Left-Control key is working fine. If I try to add a secondary shortcut for this action in System settings > shortcuts & gestures > standard shortcuts > forward one word, I got an error popup saying:

This key is not supported by Qt

My keyboard didn't change, it's a basic French AZERTY 101 keys. Is there a trick to configure something somewhere?

7

With Unity on Ubuntu 14.04, I managed to have a fully working right control key using keyboard "Français" instead of "Français (variante)", using the keyboard icon on top right of the screen.

"Français (variante)" is the default selected during installation...

I don't know how to apply that on Kubuntu, sorry !

  • It works for Kubuntu as well, thanks! The only thing is that in Kubuntu you have to choose Défaut instead Français (variante). – Polosson Apr 25 '14 at 16:22
  • I don't think this is a solution, it's just a workaround. "Français (variante)" is much better for many reasons (AltGr characters are more useful, for example there is an easy access to 'œ'). I would rather choose @Neptilo answer... – PlasmaBinturong Dec 10 '16 at 11:42
8

I had the same problem with Ubuntu 14.04, using the "French (alternative)" layout (which probably stands for "Français (variante)". The issue seems to originate from a bug in xkb.

I could solve it without changing the layout and without remapping keys.

Follow these steps:

  • Open /usr/share/X11/xkb/symbols/fr as administrator.
  • Find the line include "level5(rctrl_switch)" and remove it or comment it out. (Commenting out is done by adding // at the beginning of the line.)
  • Save the changes
  • Delete all the .xkm files in /var/lib/xkb (or move them to another folder). This will force to rebuild xkb.
  • Reboot.

This blog post (in French), addresses the problem and points to this bug entry which helped me figure out the solution.

I hope it will help a lot of French *ubuntu users.

  • 2
    Neptilo method is the best, because in french oelig and OElig are not exotic characters (œ Œ), and Français (variante) is the only one that has these with AltGr[+Shift]+o. Bien vu, bon œil ;-) – useful Jul 13 '14 at 21:13
4

I had a similar problem. My right Ctrl key stopped working after upgrading to Kubuntu 14.04. I resolved it by doing the following:

Checking the current mapping of the keys. In a terminal type:

$ xmodmap -pke | grep 37
keycode  37 = Control_L NoSymbol Control_L

This is the current binding of your left ctrl key. Now check the right key:

$ xmodmap -pke | grep 105
keycode 105 = ISO_Level5_Shift NoSymbol ISO_Level5_Shift

I had this strange ouput, clearly the right key was not binded to anything. To fix this I configured a custom .Xmodmap file:

$ echo -e 'clear control\nkeycode 105 = Control_R\nadd control = Control_R Control_L' > ~/.Xmodmap
$ xmodmap ~/.Xmodmap # apply the configuration

Hope it helps you too!

-1

Try ctrl-alt-shift (left/right)arrow

http://www.unixmen.com/quick-tip-enable-workspaces-ubuntu-14-04-lts-desktop/

protected by Community Dec 2 '14 at 11:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.