5

I have just updated my Xubuntu 13.10 to 14.04. Did not change anything. Suspend-to-RAM (standby) and hibernate both worked well in 13.10.

Now hibernate does not work any more (suspend-to-RAM still works). The machine seems to suspend to disk, but after a restart, I just get a blank screen and the hard drive is running.

What can I do?


After two months of investigation (no one could solve the problem so far), I found that under the newest Debian (XFCE) with kernel 3.2.0 hibernation works correctly. The same holds for Linux Mint Debian Edition (LMDE-201403), which is based on Debian.

Hibernation does not work under the newest Linux Mint 17 "Qiana", which is based on Ubuntu, nor under the newest Fedora 20, nor under Xubuntu 14.04. They all have a kernel version around 3.13.0.

So my conclusion is that there is something wrong or misconfigured with the newest kernels, and since the distributions that are not directly based on Debian use the newest kernels, their hibernation does not work correctly, whereas the Debian kernels do work.

  • possible duplicate of How to enable hibernation? – jobin Apr 21 '14 at 17:10
  • Did you re-enable hibernation after you upgraded? – jobin Apr 21 '14 at 17:10
  • No. How do I do it? On the logout dialogue, I have the two options, when I click, it does something like hibernate, but does not wake up correctly. sudo pm-hibernate does exactly the same: tries to go into hibernate, but does not wake up. Everything worked fine with 13.10 – ubuplex Apr 21 '14 at 18:35
  • On Dell inspiron 1525 with the same problem, uninstalling and reinstalling pm-utils seems to have done the job. Once! When trying again, the problem was still there. Anyone with more linux knowledge might figure out something from this, maybe. – user341025 Oct 21 '14 at 20:21
1

Well, after waiting for more than 6 months, the updates I got seem to have solved the problem. Hibernating works now.

The only drawback is that after suspending to ram, the sound does not work, though it can be re-enabled by hibernating followed immediately by a wake up.

3

I found that, in Lubuntu anyway, if you open synaptic and search term 'hibernate' there is a package simply called hibernate. Just install that and instead use it, not pm-hibernate. Works great, even better.

  • I can't find the package that pm-hibernate is included in! – ubuplex May 24 '14 at 8:08
  • 1
    Ok, I've found the package pm-utils and removed it. Installed "hibernate" instead. Sometimes it works, sometimes not (as before, wakeup sometimes freezes). It seems that my hardware went corrupt the day I made the update :-) This problem is driving me crazy... – ubuplex May 25 '14 at 13:52
  • 1
    A fresh install of 14.04 did not help either. – ubuplex Jun 1 '14 at 5:22
  • when you install this how do you go into hibernate in mint 17? – Nikos Aug 26 '14 at 11:16
3

I was just having an issue with my hibernation in Linux Mint 17 Cinnamon and came across this link. The article provides four potential reasons for hibernate not working and their solutions. For me, the wrong UUID was listed in /etc/initramfs-tools/conf.d/resume.

I have multiple swaps on my hard drive for other distributions, and the UUID displayed in the file did not match the UUID of the swap partition I set to mount at startup for Mint (though I did not have to add the UUID into grub, as it said I would).

Try the solutions from the site and see if they help you.

1

I had a similar issue when I upgraded from Linux Mint 16 (based on Saucy) to Linux Mint 17 (based on Trusty). Suddenly my suspend, hibernate and shutdown functions all failed to work properly. I tried many different possible solutions based on a lot of searching wikis and forums, but in the end the only thing that worked was upgrading my laptop's BIOS.

Make sure you have a backup of your files and possibly your MBR/EFI partition data before doing this. I thought I was going to lose all my data after the BIOS upgrade, but luckily I rescued it all.

I have a Lenovo Z70 laptop. After upgrading BIOS and rescuing my partitions, suspend, hibernate and shutdown all worked perfectly again. I am running a 3.17 kernel though, not the stock 3.13 that came with Qiana. But I don't think the kernel was the problem, it was the BIOS.

  • For me it helped also to upgrade the bios (V1.27 to 1.29, Lenovo X240, Mint 17) – Tapper Feb 15 '15 at 14:17
0

Try ubuplex solution. Worked for me in Linux Mint 17 Quiana (based on 14.04):

sudo apt-get remove pm-utils
sudo apt-get install hibernate 

EDIT: With this solution hibernation only works if I use "sudo hibernate" command. Badly unninstalling pm-utils makes "Hibernate" button (in power off dialog) unusable.

0

Also had a similar problem with Qiana Mint. The best I could manage after following many of the above was one hibernation - the second would freeze.

var/log/syslog yielded an error on restart concerning "rsyslogd-2039". Here's the link http://kb.monitorware.com/kbeventdb-detail-id-6904.html

Following that method produced different problems. I finally settled on changing the last line from

 *.=notice;*.=warn |/dev/xconsole
to
 *.=notice;*.=warn |/dev/null

That just left the networking problem - sometimes reconnected, sometimes not. I put these lines in a script on the Desktop

sudo service network-manager stop
sudo rm /var/lib/NetworkManager/NetworkManager.state
sudo service network-manager start

Worked for me - if anyone can see why, I'd like to know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.