14

Just installed 14.04. It seems to be converting all my screen touch gestures to mouse gestures. And it only supports one point touch. It is supposed to support ten touch points (tested with windows 8.1).

Am I missing something here? Do I have to install some kind of package? Or is it just not supported?

Test - being able to draw here: http://www.paulirish.com/demo/multi

8

This is not a problem with "multitouch", it is a problem with "touch".

Before the 14.04 update, the touchscreen was interpreted as another mouse. After the update it is not, but unfortunately Chromium is not reporting touch-events. This means that no graphical web app can be used with Ubuntu on a touch screen.

I managed to make it work on my computer by starting Chromium with the command:

chromium-browser --touch-events=enabled
  • This works! The enable-touch flag of chromium. Shame it does not work with google chrome. – civilian0746 May 7 '14 at 0:03
  • 1
    You say "no graphical web app can be used with Ubuntu on a touch screen," but you don't mention trying any browser but Chromium! Given the workaround, it sounds like it could have just been a Chromium issue? – Lambart Jul 11 '14 at 22:06
  • @civilian0746 Chrome is just the evil twin of Chromium – Hack-R Nov 18 '16 at 4:32
  • On Ubuntu 18.04 in Chromium I needed to go to chrome://flags and change the Touch Events API to Enabled. Worked for me (using Dell XPS 15 with touchscreen). Unfortunately it looks like multi-touch is not working. Test using output.jsbin.com/pevalur – robocat Dec 6 '18 at 2:54
3

I just got myself a laptop with a touch screen and have been thinking the same thing. I haven't tried it myself yet,but I just found this: https://wiki.ubuntu.com/Multitouch

Three fingers seems to be the answer, instead of two for zoom and stuff.

You might be able to use Ginn to setup your own multitouch actions: https://wiki.ubuntu.com/Multitouch/Ginn

  • That all works. But I still can not draw here: paulirish.com/demo/multi I can draw using my iPad and windows 8.1 – civilian0746 Apr 23 '14 at 23:07
  • In wiki.ubuntu.com/Multitouch/Testing/CheckingMTDevice mdiv test works and I can see inputs from all ten fingers. However, that is not translated onto the above test. – civilian0746 Apr 23 '14 at 23:22
  • All the stuff from the link I shared worked for me as well, but not that draw demo (worked on my pad, though). Maybe there isn't that use of multitouch yet. – Daniel Holm Apr 25 '14 at 9:58
  • I'll add that GINN won't work with Unity. Other shells work though. – Robbie Wxyz Oct 3 '14 at 13:41
1

In Firefox you can do this: https://support.mozilla.org/es/questions/1091627

Enter about:config and set the value of dom.w3c.touch_events.enabled to 1.

Now you can scroll.

0

PORTUGUESE to English translated by google

On Linux, since the advent of the 2.6 kernel, which support multi touch screen is enabled by default, with support for several drivers, including the default was to support implatao to Xorg, bringing benefit to all Unix like.

Hence,

If you want to perform a test to identify the support, task-level layer Multi touch screen, try the "pinch-zoom" in his native chromium browser

Run the command:

chromium --enable-pinch

Unfortunately, chromium is one of the few open source projects that come with this feature by default.

If you want to enable this support for all applications.

Use the window manager compiz.

However, Compiz does not come with the plugin, which supports the multi-touch screen capabilities.

This time, compile the plugin as per the guidelines of the site, depending on link below:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.