170

This question already has an answer here:

After installing Ubuntu 14.04 guest on VirtualBox running on a Max OSX host, I am stuck with 640x480 screen resolution. Adding guest additions again doesn't help. Previous Ubuntu installations are fine with bigger resolution. The 'Detect Displays' button on the 'Display Settings' Settings screen is not reachable, because 640x480 is too small. I could not find a /etc/X11/xorg.conf file to configure manually.

marked as duplicate by Sylvain Pineau, Eric Carvalho, αғsнιη, Amith KK, muru Oct 26 '14 at 14:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Could the persons marking questions as duplicate indicate a duplicate of what so that we can click to the answer instead of starting a new search. – Papou May 20 '16 at 0:40
  • in VirtualBox, click View>Scaled Mode... – T.Todua Jan 17 '17 at 13:30
230

Independently of your installed version of VirtualBox you should install the latest version of the VirtualBox Guest Additions into your Ubuntu-Guest. You can get it from the Ubuntu-Software-Repository.

Startup your guest and hit Ctrl+Alt+T to open a terminal session. Type

sudo apt-get install virtualbox-guest-dkms

to install the latest package. Restart the VM and enjoy screen-size.

  • 10
    Thanks so much for Ctrl-Alt-T - I couldn't even get a window up! – Casebash May 7 '14 at 3:38
  • 4
    This solution worked for me. I am using Windows 7 64bits as host. – Ricidleiv Tondatto Jul 23 '14 at 20:09
  • 1
    so awesome! I downloaded the guest additions .iso and it didn't work, but installing from command line worked like a charm. Thanks so much! – carter Jul 25 '14 at 2:51
  • 3
    You should install the guest additions shipped with the VirtualBox in Tools/Install Guest additions. – Calmarius Aug 20 '14 at 13:57
  • 6
    @Calmarius: No, you shouldn't use the shipped additions in Linux guests, because they may have incompatiblities with your guest. Thats why you should always use the latest additions, that are offered by the software repository of your guest system. – shylynx Aug 21 '14 at 10:50
17

Just had exaclty the same problem with Ubuntu 14.04 on Windows 7 VirtualBox. I've updated to latest version of Virtualbox (4.3.10 r93012) and it now works correctly. Make sure to install the latest version of Guest Additions (v4.3.10 at the moment).

  • 1
    And of course, restart the guest after doing this! – Baruch Apr 28 '14 at 8:44
  • 1
    This worked for me as well on OS X 10.9 Maverick – SPRBRN May 4 '14 at 19:09
  • Thank you very much for this. I was stuck with 640x480 until I realized I had Virtualbox 4.2 installed. – mles Dec 17 '14 at 11:21
  • @SPRBRN How do you install guest additions in OS X 10.9? – Mukus Aug 19 '15 at 4:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.