2

I know questions like that have been asked many times but I can't find a way to solve my problem even after reading them and trying the answers.

I have two screens on my desktop. Whatever I set to the /etc/X11/xorg.conf or to the /usr/share/X11/xorg.conf.d/xorg.conf files, this is how my desktop looks like when I log in (which is wrong because the wallpaper should cover the whole background on the right side):

enter image description here

Then I start nvidia-settings and when I change from this:

enter image description here

to this:

enter image description here

and apply it, my desktop looks like this:

enter image description here

which makes absolutely no sense at all to me, because I haven't touched the main screen's resolution.

I can't find a way to make X11 remember to put the small screen on the right of the big neither, nor keep the big screen as the main screen. I have tried multiple configuration files including this:

Section "Screen"

    # Removed Option "nvidiaXineramaInfoOrder" "DFP-0"
    # Removed Option "metamodes" "DVI-I-2: nvidia-auto-select @1920x1080 +1280+0, DVI-I-1: nvidia-auto-select @1280x1024 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "CRT-0:nvidia-auto-select@1280x1024+1920+0,DFP-2:nvidia-auto-select@1920x1080+0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

This issue appeared when I switched to 13.10. I have just switched to 14.04 but it hasn't improved anything.

My GPU is an nvidia GTS 450.

Anyone has a clue on how to solve this please ?

Edit: Output of xrandr:

Screen 0: minimum 8 x 8, current 3200 x 1080, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0  
   1280x960       75.0     70.0     60.0  
   1152x864       75.0     70.0     60.0  
   1024x768       75.0     70.1     60.0  
   800x600        75.0     72.2     60.3     56.2  
   640x480        75.0     72.8     59.9  
DVI-I-2 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080      59.9*+   60.0  
   1680x1050      60.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3     56.2  
   640x480        75.0     59.9  
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-I-3 disconnected (normal left inverted right x axis y axis)

DVI-I-1 should be on the right, DVI-I-2 on the left. I have tried

Option "metamodes" "DVI-I-1: 1280x1024+1920+56, DVI-I-2: 1920x1080+0+0" in both /etc/X11/xorg.conf and /usr/share/X11/xorg.conf.d/xorg.conf but the result is still the same at startup.

2

I think the issue is actually much simpler. Try opening the "Appearance" settings (right click on the Dekstop => Change Background) and set the background to "Fill":

enter image description here


If that doesn't work, try editing your /etc/X11/xorg.conf file. Leave the Screen section as is but make sure you have the following sections:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 880M"
    Option     "TwinView"
    ## Screen names are laptop's: DP-3, Philips: VGA-0 and Dell:DP-2
    Option         "metamodes" "DVI-I-2:  1920x1080, DVI-I-1: 1280x1024"
    Option         "TwinViewOrientation" "RightOf"
EndSection


Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I am not an expert on xorg.conf, the above is based on my own setup which I have finally gotten to work as I wanted. You can have a look at mine here, in case it gives you any ideas. It sets up two screens with either VGA-0 or DP-2 on the right (depending on which one is connected) and SP-3 (my laptop's) on the left.

I am pretty sure the Screen 0 "Screen0" 0 0 line in the "Server" section was very important but I did this about a year ago so I don't remember the details any more. Finally, the official nvidia documentation for xorg.conf is really very good and actually explains what the various options do. That and the Arch wiki page on NVIDIA are what helped me solve it.

  • Indeed the screen is filled when I startup this way but the resolution is bad and this still doesn't explain why X can't remember to put my small screen on the left side not to use my big screen as the main one. It's not a simple wallpaper problem, it really looks like X is getting confused and treating my small screen as my big one and my big screen as my small one. – Nicolas Seiller Apr 21 '14 at 12:51
  • @NicolasSeiller have you tried running sudo nvidia-xconfig and then clicking on "Save to X configuration file"? – terdon Apr 21 '14 at 12:54
  • Yep tried it. upon sudo nvidia-xconfig execution I get the following output: no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory Using X configuration file: "/etc/X11/xorg.conf". Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup' New X configuration file written to '/etc/X11/xorg.conf' – Nicolas Seiller Apr 21 '14 at 13:07
  • @NicolasSeiller and? Does it remember it after reboot? – terdon Apr 21 '14 at 13:09
  • Sorry, no still the same result. – Nicolas Seiller Apr 21 '14 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.