I used to modify /etc/lightdm/lightdm.conf, adding the line greeter-show-manual-login=true, in order to allow login for hidden users and root.

Now I've just installed the new Ubuntu 14.04 and the file lightdm.conf is no longer located in /etc/lightdm. It's in /etc/init and has been totally modified.

How can I force lightdm login screen to show a field to input a login name?

Ok I finally found the solution, very simple. The file to edit is now located in /usr/share/lightdm/lightdm.conf.d, and is called: 50-ubuntu.conf.

I just added the line:

greeter-show-manual-login=true

and on next reboot I was able to input any user name on the login screen.

enter image description here

  • 4
    Rather than editing a default system file, why not add your own to the lightdm.conf.d folder? – bshacklett Nov 26 '14 at 18:48
  • 1
    If you do make a completely new file as suggested by @bshacklett, you need to start it with [SeatDefaults]. – pix Jan 16 '16 at 14:34
  • For Plasma, the file is /usr/share/lightdm/lightdm.conf.d/40-kde-plasma-kf5.conf – Danny Beckett Sep 20 at 0:11

I also had the same issue with Ubuntu 14.04 installation. But I resolved the problem by following this site.

The solution is to create a file lightdm.conf inside /etc/lightdm/ and put the following contents in it:

[SeatDefaults]
greeter-show-manual-login=true

After a system reboot, I was able to login with other users.

  • On the Ubuntu 14.04 64bit the configuration file changed to /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf But on 32bit is same as before – user3597121 Aug 21 '14 at 15:30

Also you should do following step:

update /etc/pam.d/common-session and change the line:

session sufficient pam_lsass.so

to:

session [success=ok default=ignore] pam_lsass.s

After a reboot, my path was ok, and everything seems to be working as normal again.

See the bug report

In addition to the greeter-show-manual-login=true option, one could use greeter-hide-users=true. Personally that's that I have in my /etc/lightdm/lightdm.conf : the manual login option is commented out, with only hide users option left.

  • If I understand you correctly, this option only allows login as a guest user. – gone Jul 15 at 18:58
  • @gone no, login is allowed for all users, not just guest. You just have to type username, instead of choosing from a list in the greeter – Sergiy Kolodyazhnyy Jul 15 at 19:15
  • Not on my install. There is no where to type a username. There's just a label with Guest Session and the button Log In >, and if you click or press enter, the guest user logs in. Using the up/down arrows does not help either. Switching users after logging in as guest also doesn't work. – gone Jul 18 at 15:45
  • @gone And what version of Ubuntu you're using ? – Sergiy Kolodyazhnyy Jul 18 at 15:48
  • U14.04.3 LTS in a VirtualBox VM on a Macbook Pro with MacOS. – gone Jul 20 at 13:28

protected by Community Aug 21 '14 at 17:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.