1

So last night I tried to update using the update manager and I couldn't because I encountered an error halfway through (error:brokencount>0). Today I wanted to install a package with ubuntu software center and I got an error message telling me there is a problem that needs to be fixed because my package system is broken, there was a repair button but that didn't fix anything and instead gave me another error message..

this is what I get when doing upgrade in the terminal

robin@robin-1005PX:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 liboxideqtcore0 : Depends: oxideqt-codecs (= 1.0.0~bzr501-0ubuntu1) but 1.0.0~bzr501-0ubuntu2 is installed or
                            oxideqt-codecs-extra (= 1.0.0~bzr501-0ubuntu1) but it is not installed
E: Unmet dependencies. Try using -f.

and this is what I get when running sudo apt-get install -f

robin@robin-1005PX:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  liboxideqtcore0
The following packages will be upgraded:
  liboxideqtcore0
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/20,8 MB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 168238 files and directories currently installed.)
Preparing to unpack .../liboxideqtcore0_1.0.0~bzr501-0ubuntu2_i386.deb ...
Unpacking liboxideqtcore0:i386 (1.0.0~bzr501-0ubuntu2) over (1.0.0~bzr501-0ubuntu1) ...
dpkg-deb (subprocess): cannot copy archive member from '/var/cache/apt/archives/liboxideqtcore0_1.0.0~bzr501-0ubuntu2_i386.deb' to decompressor pipe: failed to read (Input/output error)
dpkg-deb (subprocess): decompressing archive member: lzma error: unexpected end of input
dpkg-deb: error: subprocess <decompress> returned error exit status 2
dpkg: error processing archive /var/cache/apt/archives/liboxideqtcore0_1.0.0~bzr501-0ubuntu2_i386.deb (--unpack):
 cannot copy extracted data for './usr/lib/i386-linux-gnu/libOxideQtCore.so.0' to '/usr/lib/i386-linux-gnu/libOxideQtCore.so.0.dpkg-new': unexpected end of file or stream
Errors were encountered while processing:
 /var/cache/apt/archives/liboxideqtcore0_1.0.0~bzr501-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

does anyone know how I can fix this issue? it's pretty annotying because I can't install anything and updating is also impossible.. thanks in advance!

  • it shows Input/output error. Please check for bad blocks on your disk. – Avinash Raj Apr 21 '14 at 9:47
  • how do I do that? I tried self-test in the disk utility but it failed? – user271855 Apr 21 '14 at 10:09
  • It is well discussed here: ubuntuforums.org/showthread.php?t=2154638 I was unable to find a worthwhile solution as, apparently, my upgrade wrecked a bunch of random stuff. Wiping and reinstalling seems the only trustworthy ubuntu upgrade scenario. – user272079 Apr 23 '14 at 21:33
  • I managed to fix the issue by repeatedly using apt get update, install -f, clean, configure and upgrade – user271855 Apr 25 '14 at 4:38
  • I just experienced the same issue. As a result of this problem, my system even failed to load mouse drivers and WLAN drivers. That means I have no more internet connection and can't even use eg. sudo apt-get -f install or sudo apt-get update. – John Slegers Sep 15 '15 at 9:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.