2

I have tried all the known solutions and it still won't work. I have tried the brcm modprobe after updating the firmware library as well as doing the blacklist thing for bcm43xx. Is there a fix for this??

-------edit------

The lspci -nn command wouldn't do anything lspci I cant post pictures yet but here is the output lspci

     lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
  • Can you add the output of lspci anyway. – mikewhatever Apr 21 '14 at 12:53
  • Please post the output of the following: "lspci -nn | grep Network" – Luis Alvarado Apr 22 '14 at 19:42
  • Ok I edited it. – j3lam Apr 25 '14 at 19:35
2

you must copy the file called brcmfmac43241b4-sdio.txt to /lib/firmware/brcm where it accompagnies the driver called brcmfmac43241b4-sdio.bin.

Normaly this is created using nvram-tools but it does not work on the sony pro 13 and I copied one from the net. Your can download one from the net

| improve this answer | |
  • Are there any steps in addition to this one that I need to use?? Because I have put both files in the proper location, and it still doesn't work – j3lam Aug 28 '14 at 23:32
  • How do you build/find/get the brcmfmac43241b4-sdio.txt file? – naisanza Aug 23 '15 at 6:06
0

For the Sony Vaio Pro Duo 13 might have possibly found an answer on this post: http://iswwwup.com/t/6e143a545283/broadcom-ldquo-no-network-devices-available-rdquo-for-bcm43241-sdio-after-fresh.html

There are two links to two different files:

https://github.com/jfwells/linux-asus-t100ta/blob/master/nvram/lib/firmware/brcm/brcmfmac43241b4-sdio.txt

https://www.dropbox.com/s/8m9n4qolf76iz11/brcmfmac-sdio.zip

The latter, the user claimed to have contacted a developer from Broadcom, and it is the file the developer provided.

Here's that user's quote

After contacted a developer of broadcom, he gave me mails between him and an user who had same issue but have successfully solved this. The user helped me by sending another nvram and firmware (a bin and a txt) and it worked. I think it's just because the wireless card is too new for the current kernel (correct me if I say something wrong as a novice of linux).

Before brcmfmac-sdio.zip:

dmesg:

[    1.876661] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 4324 rev 5 pmurev 17
[    1.877893] usbcore: registered new interface driver brcmfmac
[    1.888464] brcmfmac_sdio mmc0:0001:1: firmware: direct-loading firmware brcm/brcmfmac43241b4-sdio.bin
[    1.888486] brcmfmac_sdio mmc0:0001:1: firmware: failed to load brcm/brcmfmac43241b4-sdio.txt (-2)
[    1.888550] brcmfmac_sdio mmc0:0001:1: Direct firmware load for brcm/brcmfmac43241b4-sdio.txt failed with error -2
[    2.891252] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50

After brcmfmac-sdio.zip:

dmesg:

[ 1548.361470] usbcore: deregistering interface driver brcmfmac
[ 1553.562888] brcmfmac: brcmf_sdio_drivestrengthinit: No SDIO Drive strength init done for chip 4324 rev 5 pmurev 17
[ 1553.563246] usbcore: registered new interface driver brcmfmac
[ 1553.563343] brcmfmac_sdio mmc0:0001:1: firmware: direct-loading firmware brcm/brcmfmac43241b4-sdio.bin
[ 1553.563352] brcmfmac_sdio mmc0:0001:1: firmware: direct-loading firmware brcm/brcmfmac43241b4-sdio.txt
[ 1553.709778] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: Jul 17 2013 07:36:07 version 6.10.197.71 (r412987) FWID 01-882d2634
[ 1553.723455] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[ 1553.764370] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 1553.764376] brcmfmac: brcmf_add_if: ignore IF event
[ 1563.827235] brcmfmac: brcmf_escan_timeout: timer expired

We can see that, because the brcmfmac43241b4-sdio.txt file now exists, it is able to finish loading the brcmfmac module. But it doesn't work, completely. Such as, you can't set the wireless interface to monitor mode, and you can't use iw to scan for routers.

root@chickenbutt:~# ifconfig wlan0 down
root@chickenbutt:~# iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not supported.
root@chickenbutt:~# iwconfig wlan0
wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on

This is what happens if you try to use iw to scan for networks:

root@chickenbutt:~# iw wlan0 scan
scan aborted!
| improve this answer | |
0

I have also had the same problem, adding brcmfmac43241b4-sdio.txt to

/lib/firmware/brcm/

did not solve my problem. After I restarted the kernel module "brcmfmac" with:

sudo modprobe -r brcmfmac && sudo modprobe brcmfmac

my wifi came to life but it was not functional (it did NOT display all SSID's in its range) and trying to scan with:

sudo iw wlan0 scan

would abort. The way I fixed this was by updating to the 4.1 kernel. I created two scripts to automate these two tasks

updateKernelTo4.1.sh

#!/bin/sh

mkdir ~/Downloads/kernel\ 4.1/

cd ~/Downloads/kernel\ 4.1/

sudo wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.1-unstable/linux-headers-4.1.1-040101-generic_4.1.1-040101.201507030635_amd64.deb

wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.1-unstable/linux-headers-4.1.1-040101_4.1.1-040101.201507030635_all.deb

wget kernel.ubuntu.com/~kernel-ppa/mainline/v4.1.1-unstable/linux-image-4.1.1-040101-generic_4.1.1-040101.201507030635_amd64.deb

sudo dpkg -i linux-headers-4.1*.deb linux-image-4.1*.deb

fixWIFI.sh

#!/bin/sh

echo "if it fails...try explicitly executing: bash fixWIFI.sh"

kernelVersion=$(uname -r)
kernelSubVersion=${kernelVersion:2:1}
kernelVersion=${kernelVersion:0:1}

if [ $kernelVersion -ge 4 ]; then
  if [ $kernelSubVersion -ge 1 ]; then

  cp /sys/firmware/efi/efivars/*nvram* brcmfmac43241b4-sdio.txt

  echo "you need to edit brcmfmac43241b4-sdio.txt and remove all non-text parts"

  read -p "press [ENTER] when done editing" temp

  sudo mv brcmfmac43241b4-sdio.txt /lib/firmware/brcm/

  echo restarting module...

  sudo modprobe -r brcmfmac && sudo modprobe brcmfmac

  echo "done, if it doesn't work right away try a reboot"

  exit

  fi

fi

echo " the kernel version is not high enough"
echo " try running ~/Documents/updateKernelTo4.1.sh"
echo " if the update breaks the desktop and it wont load execute: sudo apt-get --reinstall ubuntu-desktop"
| improve this answer | |
0

The following steps (based on kwoby's answer) worked for me:

  1. Download brcmfmac43241b4-sdio.txt from https://github.com/jfwells/linux-asus-t100ta/blob/master/nvram/lib/firmware/brcm/brcmfmac43241b4-sdio.txt
  2. copy file to /lib/firmware/brcm/
  3. reboot
  4. Check for interface.

Here's the commands I used:

wget https://github.com/jfwells/linux-asus-t100ta/raw/master/nvram/lib/firmware/brcm/brcmfmac43241b4-sdio.txt
sudo sudo cp brcmfmac43241b4-sdio.txt /lib/firmware/brcm/
sudo reboot

# <test after restart>
ifconfig
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.