2

I'm trying to install fglrx manually from the AMD website however it keeps complaining that it's missing the dependency "libc6-amd64".

When I run the fglrx package through gdebi I get this message:

This package is uninstallable
Dependency is not satisfiable: libc6-amd64 (>= 2.9)

Even though it's installed...

dpkg -l | grep libc6
ii  libc6:amd64                                           2.19-0ubuntu6                                       amd64        Embedded GNU C Library: Shared libraries
ii  libc6:i386                                            2.19-0ubuntu6                                       i386         Embedded GNU C Library: Shared libraries
ii  libc6-amd64                                           2.19-0ubuntu6                                       i386         Embedded GNU C Library: 64bit Shared libraries for AMD64
ii  libc6-dbg:amd64                                       2.19-0ubuntu6                                       amd64        Embedded GNU C Library: detached debugging symbols
ii  libc6-dev:amd64                                       2.19-0ubuntu6                                       amd64        Embedded GNU C Library: Development Libraries and Header Files
ii  libc6-i386                                            2.19-0ubuntu6                                       amd64        Embedded GNU C Library: 32-bit shared libraries for AMD64

In the end, I managed to get fglrx to install using the below command which ignored all dependencies:

sudo dpkg -i --force-all fglrx*.deb

Though I was wondering if anyone knows how to fix this since in apt I now get this error:

apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 fglrx : Depends: libc6-amd64 (>= 2.9) but it is not installable
 fglrx-amdcccle : Depends: libc6-amd64 (>= 2.3) but it is not installable
E: Unmet dependencies. Try using -f.
1
1

I find a workaround while searching on google. I recompiled libc6 and its other packages. It fixed unmet dependency problem of Amd's binary Ubuntu package.

First, Add source code repositries on Ubuntu Software Center ( https://help.ubuntu.com/community/Repositories/Ubuntu )

I rebuilt libc6-amd64 Ubuntu package:

sudo apt-get update && sudo apt-get --compile source libc6-amd64

I installed all eglibc (Embedded GNU C Library) packages with overriding problems.

Packages must created under directory that you gave "apt-get --compile source libc6-amd64" command:

sudo dpkg --force-all -i *.deb

Then, give same command to install your Amd Ubuntu packages:

sudo dpkg -i --force-all fglrx*.deb

It must install your Amd Ubuntu packages.

If you try to reinstall your Amd Ubuntu Packages, you have to reinstall libc6 and libc6-amd64 ( eglibc ) packages again.

It is my simple solution to fix dependency problem.

2
  • Thank you, it installs and works! But dependencies still stay in a broken state: The following packages have unmet dependencies: fglrx : Depends: libc6-amd64 (>= 2.9) but it is not installable fglrx-amdcccle : Depends: libc6-amd64 (>= 2.3) but it is not installable. Should I creat dummy package which provides libc6-amd64 2.9 to fix it? – defhlt Sep 12 '14 at 9:48
  • Also had the same problem. The dependency problem is still there. – Khronos Sep 28 '14 at 1:37
0

There are two ways to fix problem:

a) Patching generated packages https://gist.github.com/dz0ny/b9e3fce83d0c52e16857
b) Generating virtual package libc6-amd64 which lists libc6:amd64 as dependecy

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.