1

In the bootup-manager, I have disabled cups because I don't have any printers connected to my laptop. But, still the cups service gets automatically started. How to disable such services? BTW, I am using 14.04.

enter image description here

I changed the permission of the /etc/init.d/cups* files to 000 and still on reboot I see the services when I run the ps -aef | grep -i cups command.

praveensripati@MyUbuntuLaptop:/etc/init.d$ ls -ltr cups*
---------- 1 root root 3184 Apr  3 22:19 cups
---------- 1 root root 1961 Apr  7 21:04 cups-browsed

praveensripati@MyUbuntuLaptop:/etc/init.d$ ps -aef | grep -i cups
root      1154     1  0 18:26 ?        00:00:00 /usr/sbin/cups-browsed
root      3083     1  0 18:26 ?        00:00:00 /usr/sbin/cupsd -f
lp        3087  3083  0 18:26 ?        00:00:00 /usr/lib/cups/notifier/dbus dbus:// 
lp        3088  3083  0 18:26 ?        00:00:00 /usr/lib/cups/notifier/dbus dbus:// 
lp        3089  3083  0 18:26 ?        00:00:00 /usr/lib/cups/notifier/dbus dbus:// 
lp        3090  3083  0 18:26 ?        00:00:00 /usr/lib/cups/notifier/dbus dbus:// 
lp        3091  3083  0 18:26 ?        00:00:00 /usr/lib/cups/notifier/dbus dbus:// 
praveen+  3466  3129  0 18:33 pts/14   00:00:00 grep --color=auto -i cups
3

To disable the cups service via upstart, try running the following as root:

echo "manual" > /etc/init/cups.override

You can become root by running: sudo -s or su

Taken from the Upstart Cookbook

This stanza will tell Upstart to ignore the start on / stop on stanzas. It is useful for keeping the logic and capability of a job on the system while not having it automatically start at boot-up.

Example:

manual
  • Looks like bum is not UI for upstart, but is picking up the upstart service status. – Praveen Sripati Apr 21 '14 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.