9

I have an Asus laptop with a nVidia card. lspci tells me:

01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev a1)

I did a fresh install of Ubuntu 14.04 LTS (64-bit edition).

By default, Ubuntu 14.04 uses the nouveau drivers, but they don't work very well (blinking cursor, slow 3D display, etc.), so I would like to install the proprietary nvidia drivers.

I go in System Settings > Software & Updates > Additional Drivers. Ubuntu proposes me the following options:

Additional Drivers options

Whatever I try to select (other than Nouveau), after I click on "APply Changes", it reverts to Nouveau without any additional feedback...

So I tried to install the drivers manually with apt:

$ sudo apt-get install nvidia-331
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-331 : Depends: lib32gcc1 but it is not going to be installed
              Depends: libc6-i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

If I try to manually install the packages mentioned, I get this error:

$ sudo apt install lib32gcc1 libc6-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libc6-i386 : Depends: libc6 (= 2.19-0ubuntu5) but 2.19-0ubuntu6 is to be installed
E: Unable to correct problems, you have held broken packages.

What can I do to fix this?

Also, do you think it's a bug? (if so I will raise it in Launchpad)

Thanks in advance!

7

OK, it looks like the update server used (Taiwan) is not up-to-date, leading to unmet dependencies and other problems.

In order to fix that, I went to System Settings > Software & updates > Ubuntu Software and selected "Download from: Main server" (it was previously "Download from: Server for Taiwan")

The proprietary drivers can now be installed.

  • 1
    I had the same problems before. If you are located somewhere in East Asia, then the best server that always worked for me (and way much faster than the main server) is the jaist server in Japan. – Majal Aug 13 '14 at 12:24
  • +1 Had the same problem and it was fixed with your solution! Thank you! – Adam Apr 3 '16 at 21:38
0

I too experienced the same error message. In my case, it was because my apt cache was corrupt/outdated.

So anyone facing the same error make sure that your package definition is up to date.

apt-get update && apt-get install nvidia-331

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.