34

In xubuntu, my desktop icons have dissapeared. I can not remember the cause, but if I do, I will edit this and put it here. Also, when I try to right click on the desktop, nothing happens. I have tried many reboots, but nothing worked. If I have to reset what was on my desktop, that is fine, because all that was on it was some shortcuts to some files.

EDIT: I can view my desktop files from the file manager, if that helps.

1
  • 1
    I add the same ! I was caused by a fail update of linux kernel. My /boot folder was full. To check that : In a terminal, type df /boot if it is full (100%), you can clean it using this tutorial : ubuntuhandbook.org/index.php/2016/05/… Look at "Remove Old Kernels via DPKG". Et en français : justegeek.fr/… ;)
    – Sasha
    Sep 20, 2017 at 13:20

6 Answers 6

49

Answered by OP in comments:

navigate to ~/.cache/sessions/

delete any xfce*session directories

run xfdesktop (as your normal user, not root)

logout and log in again

4
  • Is that a permanent solution? I mean every time he will have to write xfdesktop to view. Jan 11, 2015 at 16:16
  • No. Logout and login again.
    – ubuplex
    May 21, 2015 at 15:50
  • 5
    @Ruud found the permanent solution below -- just rm -R ~/.cache/sessions/* then xfdesktop and sudo reboot
    – hobs
    Jun 28, 2016 at 5:31
  • It would be nice to know why this is happening? I have two computers that will get this issue every once in a while. It's very annoying and apparently this solution here is not a permanent one. Apr 15 at 13:51
9

I was having the same problem; xfdesktop (the XFCE desktop manager) should start up automatically, but from one day to another, it stopped doing so.
Symptoms: no wallpaper, no desktop icons, no desktop context menu, no response to Alt+F2.

The problem spontaneously disappeared after taking the following steps. Step 1 is probably sufficient, but since I can no longer reproduce the problem, there is no way of knowing for sure.

  1. rm -R ~/.cache/sessions/* (shell command) as suggested here
  2. log out and log in again (without rebooting in between); based on this post

Since cleaning the session cache is also suggested here, I suppose the problem may have been triggered by a repository update of XFCE.

3
  • Didn't work for me Aug 20, 2018 at 8:03
  • @Zeta.Investigator Sorry to hear that. Did any of the other answers help? If so, then you may want to try the exact steps given by hobs (rm, xfdesktop, reboot) to make the fix permanent. If not, then your problem may be different. Aug 20, 2018 at 10:40
  • thanks for reply. Yeah I've followed hobs solution and it is working for now but I don't know whether it is permenant Aug 20, 2018 at 13:28
2

This command worked for me:

xfdesktop --replace
0
0

Try:

xfdesktop --reload

If that doesn't work, log out and log back in. If that doesn't work, open Settings Manager > Desktop and check the Icons tab and make sure 'Icon type' is set to 'File/launcher icons'.

0

#!/bin/sh

rm -dvRf /home/nl/.cache/sessions/*

xfdesktop --reload

A bash file placed in "/home/user/" will make running this, if your problem repeats, stupid easy.

Next time it happens: ctr+alt+t and type "bash -insert what name you gave it- " press enter, and your done.

Also if this is one too many steps for your future self you can make a .desktop that will run the bash. One click, and your problem will go away.

copy this into a .txt file and save it as -insert what name you gave it- .desktop should look like "fix.desktop" while you're saving.

#!/usr/bin/env xdg-open

[Desktop Entry]

Name=-insert what name you gave it-

Comment=fix your desktop

Exec=bash -insert what name you gave it-

Icon=/usr/share/icons/-whatever you like for its icon-

Terminal=true

Type=bash

Categories=System

AND if that one click is STILL to much for future you, once you have the .desktop file you can open your start up applications and add it to the list of applications that start when you login, causing it to run every time you log in, and preventing you from ever needing to deal with this again...

0
0

Ubuntu 20.04.4 LTS my problem was expermenting with "desktop settings" ... submenu => "icons" there is "Appearance - icon types - I selected "none" and correct is "File/Launcher icons"

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.