10

I just upgraded from 13.10 to 14.04 (GNOME interface) and none of the shortcut key combinations or Fn+F(#) controls seem to be working any more (not even the default ones, like Ctrl+Alt+T for terminal). Additionally, I have an HP wireless keyboard with extra media control and volume toggle buttons. These no longer function either. Going to Settings->Keyboard->Shortcuts and attempting manual changes doesn't work.

What changed in 14.04 to cause this? I never had any problems at all with Saucy! I didn't change my keyboard configuration or anything like that, and when I tested the keys with showkey they all worked, so something got lost with the keyboard mapping when the upgrade happened.

3

Killing unity-settings-daemon and running gnome-settings-daemon worked for me , or running:

gnome-settings-daemon --replace

But it's not a persistent solution. It affects all keyboard shortcuts set via
SystemSettings...→Keyboard→Shortcuts. Running Ubuntu 14.04.

(also maybe interesting: some shortcuts that were set before updating from 13.04 to 14.04 still worked, but as soon as I reassign them in the System Settings, they stop working with unity-settings-daemon)

| improve this answer | |
  • This can lead to the loss of data. Be sure to save all your data and close all programs before doing it. – pvc Dec 24 '15 at 23:54
  • @pvc, can you explain which data might be lost? – Tyler Collier Jan 3 '16 at 2:35
  • @TylerCollier Everything that is not saved. In my case whole X server restarted few seconds after running that command. – pvc Jan 3 '16 at 14:50
3

Here is the bug report https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1302885 & here you go, this should do the trick...

The problem is that an incorrect string is set in dconf key: (Example)

Original (working) value:

gsettings get org.gnome.settings-daemon.plugins.media-keys volume-up
'XF86AudioRaiseVolume'

After running "unity-control-center keyboard", and setting the shortcut for volume-up key:

gsettings get org.gnome.settings-daemon.plugins.media-keys volume-up
'AudioRaiseVolume'

The new value misses the "XF86" part of the string, and does not work.

You can get the key working again by resetting the value, with:

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up

to reset key using GUI, you can install dconf-tools:

sudo apt-get install dconf-tools
| improve this answer | |
  • This worked well for me after SystemSettings...→Keyboard→Shortcuts remapping broke the Media keys functionality. The 3 commands to restore Audio control were: gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up & gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down & gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute . – Chrisky Jun 27 '14 at 22:06
  • Worked here too. I just used Dconf, browsed to Org/Gnome/Settings-Daemon/Plugins, then hit the "reset" button on all the media entries. Thanks for this. – Scaine Oct 13 '14 at 13:03
2

As stated by @robin-hood, it looks like a known bug on Launchpad.

According to the thread there, the current simple fix is to...

  1. Open terminal (Ctrl+Alt+T)
  2. Type the following two commands to reset the volume keys on your keyboard...

    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
    gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
    

It worked for me, hope it works for you too.

| improve this answer | |
  • 1
    "volume-mute" can be used, too – Chrisky Jun 27 '14 at 22:11
2

I've tried a number of proposed solutions (for Ubuntu 14.04), however this worked for me. From a terminal type (or copy paste.. Note you need to use Ctrl+Shift+V to paste in to a terminal);

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute
| improve this answer | |
1

I had the same problem, updatet from Ubuntu Gnome 13.10 to 14.04. Something happened at this process, so gnome3 didn't work properly. I could control my background light, but without OSD, volume buttons, other fn-keys didn't work and Ctrl+Alt+T didn't open the terminal. So I decided to upgrade gnome-shell to 3.12, I realised, that my main gnome3 ppa's were disabled (which is normal while upgrading Ubuntu) so you could also try enabling those by typing:

sudo add-apt-repository ppa:gnome3-team/gnome3

afterwards, to update gnome3 type:

sudo apt-get update && sudo apt-get dist-upgrade

If you want to try gnome 3.12 add the main repository but afterwards also add the staging by typing

sudo add-apt-repository ppa:gnome3-team/gnome3-staging

and type:

sudo apt-get update && sudo apt-get dist-upgrade

afterwards.

Reboot and everything should work!

good luck!

| improve this answer | |
0

On Xubuntu 14.04 I had to (re)enable gnome-settings-daemon to get the media keys working again.

| improve this answer | |
  • 1
    Ah, that might be it. Hm. I'm getting this message when I try running gnome-settings-daemon --debug: ** (gnome-settings-daemon:4161): WARNING **: Name taken or bus went away - shutting down ** (gnome-settings-daemon:4161): DEBUG: Shutting down ** (gnome-settings-daemon:4161): DEBUG: SettingsDaemon finished – pianoplunkster Apr 29 '14 at 21:35
0

I don't have the gnome environment installed, but still ran into the same symptoms. I'm not certain why, since my install has been working fine for a few months, but just today all the shortcuts in the "Keyboard settings" ceased to work. As is hinted at briefly at the bottom of this thread, there seems to be a bad gnome configuration. I tried removing my ~/.gconf folder (after making a backup first!) and logging out/in, and that fixed my problem. The full steps to fix were:

  1. Open up your home folder by pressing the Windows (or meta) key or by clicking on the first icon in the doc, then typing Files and opening the Files application.
  2. Show hidden files and folders by pressing Ctrl+H.
  3. Find the .gconf folder and rename it to .gconfg.bak.
  4. Hide hidden files and folders again by pressing Ctrl+H.
  5. Log out of your account and back in. while many of your settings will be back to default, your shortcuts should work again.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.