Environment: Lenovo T530 running Windows 7. Have installed Ubuntu 14.04 on a virtual machine using VM Virtual Box. Have installed all the updates from both Virtual Box and Ubuntu.

Problem: While in Ubuntu's desktop and other Ubuntu initiated programs, the window is reduced to about 3x4 inches showing in the middle of the rest of my regular Virtual Box window. I am seeing only the upper right hand of the screen output of what I would normally see.

I've seen How do I install Guest Additions in a VirtualBox VM?

But, none of these answers works in 14.04.

  • 7
    I don't think this is a duplicate. When installing the Guest Additions with Ubuntu 14.04 I get "Warning: unknown version of the X Window System installed. Not installing"
    – mjaggard
    Apr 22, 2014 at 15:31
  • 3
    This is definitely not a duplicate question (even if the answer is the same). I found this only via searching about screen res problems, and learned here that "guest additions" is the answer. (If I already knew to ask about "guest additions", I wouldn't have had a question/problem.) Jun 22, 2014 at 0:56
  • 3
    The answers aren't even the same. Generally you would use the guest additions iso that can be mounted from the host, but it seems to be specific for 14.04 that you must install via the apt repo for it to work properly.
    – flungo
    Jul 26, 2014 at 9:22
  • 2
  • 2
    I've been having problems with this as well. Guest additions appears to have installed correctly but full screen mode still has a small os display. kraxor, where are you seeing system settings?
    – user322522
    Sep 1, 2014 at 5:33

9 Answers 9


You basically need the Guest additions, log into the Virtual Machine to install the following packages:

sudo apt-get install virtualbox-guest-dkms

Finally restart the VM to complete the installation.

  • 6
    Thanks, I misunderstood this step before I read your answer and thought I was supposed to install Guest Additions on the host machine. d'oh.
    – Aaron
    Dec 29, 2014 at 18:08
  • 7
    @symphonyblade: Those packages are meant to be installed on the Guest OS indeed. Dec 29, 2014 at 18:50
  • 42
    Doesn't work on my Ubuntu 14.04 LTS installation. I get The following packages have unmet dependencies: virtualbox-guest-x11: Depends: xorg-video-abi-15 Depends: xserver-xorg-core (>= 2:
    – THelper
    Mar 4, 2015 at 12:09
  • 43
    @THelper On ubuntu 14.04 I also got The following packages have unmet dependencies. virtualbox-guest-x11 : Depends: xorg-video-abi-15.... The solution by @conradk under here worked for me: sudo apt-get remove libcheese-gtk23, then sudo apt-get install xserver-xorg-core and finally sudo apt-get install -f virtualbox-guest-x11
    – snark
    May 11, 2015 at 14:31
  • 2
    This didn't work for me at all. Still a tiny screen. May 15, 2016 at 17:34

On virtualbox you have to install "Guest Additions". There is no need to set a resolution via Ubuntu settings. With your guest window in the foreground select from the top menu:

VirtualBox -> Devices -> Insert Guest Additions CD image

In Ubuntu open a terminal, navigate to cd folder (usually /media/VBOXADDITIONS*) and run

sh ./VBoxLinuxAdditions.run

Note that you should have a working compiler gcc/g++

  • 3
    This fails with an error saying it looks like guest additions had been installed from a different installer or package. The only solution is the answer saying to use apt-get to install the three packages. Jun 25, 2014 at 20:00
  • 2
    Exactly the same here trying to install Xubuntu 14.04 64bit on VirtualBox. Installing Guest Additions from mounted CD image is not working - it breaks X Server installation. Instaling with apt-get from public repositories as advised by Sylvain works.
    – azec-pdx
    Jul 31, 2014 at 11:36
  • 5
    +1 This is the only solution that worked for me. As a preliminary step, it was very important to update the VirtualBox Manager to the latest version available. I have posted here a new answer with some additional details.
    – Antonio
    Mar 10, 2015 at 17:26
  • 1
    Though an error appeared that says guest additions has been installed from a different installer..etc do you want to continue,answer with a Yes , after it finishes reboot and it will work Jun 17, 2015 at 11:11
  • 1
    +1 worked for me - Virtualbox 5.0.10 Mac Jan 14, 2016 at 21:12

I had the same problem as you. I did these steps, maybe helps you too:

  1. Go to System settings → Software and Updates → Additional drivers
  2. Use x86 virtualization solutions...
  3. After that reboot your VirtualBox

My VirtualBox is working perfectly.

  • 1
    Oh my gosh. After trying so many other things and wasting so much time, this easy solution did the trick. Jan 26, 2015 at 22:51
  • 4
    Setting this option seems to go ok on my Ubuntu 14.04 LTS installation, (no error messages) but after the reboot I still have 640x480 resolution and no option to change it.
    – THelper
    Mar 4, 2015 at 12:20
  • 2
    On a fresh image of 14.04.2 desktop (retrieved from osboxes.org), when I boot I'm in 640x480. I then open System Settings -> Software and Updates -> Additional Drivers. There is no option to choose 'Use x86 virtualizations solutions'. Is it simply hidden because of resolution? Do I have to install the Guest Additions first?
    – Ezward
    Jun 7, 2015 at 20:22
  • 2
    Did not help for me
    – Daniel
    Jun 10, 2015 at 6:01
  • 2
    On my Unbuntu 14.04 LTS installation there is no "Software and Updates" under System Settings". I see two categories of stuff there, "Personal" and "Hardware". Perhaps there is a third category I'm not seeing because ... my screen is too small?
    – T.E.D.
    Dec 30, 2015 at 15:42

After having first tried installing the Guest additions, which didn't work, I found another solution elsewhere: linuxbsdos.com.

Use Xdiagnose from the Dashboard. Search for and launch Xdiagnose, then enable all the options under the Debug section. Click the Apply button, then close the window and restart the system.

That's what finally did the trick! Now I get 1024 x 768 resolution instead of 640 x 480.

I never uninstalled the Guest additions, so it might be I needed to take both these measures.

enter image description here

---------- EDIT ---------

I have come to realize that the solution described above is just a fallback, in case installing the Guest Additions failed for some reason. I have finally managed to successfully install them, and can now choose from a bigger range of resolutions in the display settings. Here is how I did it, after having tried all of the above.

One thing I had already tried earlier was

sudo apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11
This is not enough in itself, but might be a necessary prerequisite for the following steps (of which some might not be necessary...).

  1. Update Virtualbox to the latest version (currently 4.3.24)
  2. In Terminal in the Guest system type:

    sudo apt-get install dkms
    sudo apt-get install build-essential module-assistant
    sudo m-a prepare

If you have no top menu in the Guest system, it's because you're in scale mode which causes it to be hidden. In that case, press Host + C to toggle scale mode (where Host is Right Control by default)

  1. In the Guest system, go to the top menu, and click Devices->Insert Guest Additions CD Image. This should mount the CD image.
  2. In my case, Autostart worked, and the installation started with a prompt. If it doesn't autostart, you can do the following

    cd /media/<username>/VBOXADDITIONS_4.3.10_93012
    sudo ./VBoxLinuxAdditions.run

Just be sure to replace <username> by the logged in user's username.

And then a restart, as JTIM pointed out...

  • 3
    Well, it did enable 1024x768 for me, that's at least something. It still doesn't allow me to set anything higher though, despite trying all the other solutions.
    – sp00n
    Mar 4, 2015 at 11:15
  • +1 Your solution solved it for me as well!
    – THelper
    Mar 4, 2015 at 14:36
  • 1
    I got it to work at any resolution following these steps.
    – Antonio
    Mar 10, 2015 at 17:24
  • 2
    Great update! I'm not sure all steps are necessary (dkms is already up-to-date if you first install virtual-guest-dkms), but it certainly worked for me! The virtual box window with Ubuntu now automatically scales to all resolutions. Oh, and I needed to exclude the virtualbox-guest-x11 in your first step.
    – THelper
    Mar 19, 2015 at 13:56
  • 1
    and then a restart :)
    – JTIM
    Apr 8, 2015 at 10:08

Developing from this answer, and in fact pretty well explained also in this other post. (I really tried everything else posted here but it does not seem to work on my Windows 7 system)

Preliminary steps:

  1. Make sure you have installed the latest version of Virtual Box(*). Be careful that if you ask Virtual Box to update to the latest version it might very likely declare being updated even if a newer version exists!

  2. It might be a good idea to start from a clean distribution, creating a new virtual machine, install there Ubuntu (I allowed downloading updated packages from the network during installation), and cloning it before proceeding, so that if you have troubles you can avoid restarting from the very beginning.

  3. Install build-essential and linux-headers-generic packages. Apparently, it's also reccomended to install dkms, as "Running DKMS in the guest OS will keep Guest Additions installed after a guest kernel update".

How to:

  1. Start your virtual machine

  2. On Virtualbox menu -> Devices -> Insert Guest Additions CD image...

  3. From Ubuntu you should see a popup, allow the CD autorun to install the program. For me, like many times before, it said he could not find Linux headers but, this time, in the end everything went fine.
    If the autorun does not work, open a terminal (Ctrl+Alt+T), navigate to folder (usually /media/VBOXADDITIONS*) and run

    sh ./VBoxLinuxAdditions.run

  4. Shut down and then start again your virtual machine

(*) If, like me, with the new version of the Virtual Box you have trouble with network, take a look at this video (In short: use Bridged network, and select "allow VMs")

  • Excellent. Out of all the answers, this is the only one which worked for me, with Ubuntu 14.04.2 64 bit guest and Windows 7 host. Mar 18, 2015 at 11:02
  • Awesome, this solution actually worked perfectly after trying many others! Thank you!
    – jaseeey
    Apr 19, 2015 at 13:20
  • This did work after so many failure attempts.
    – Jdbaba
    Jun 11, 2015 at 18:28
  • Worked like a charm on my Windows 7 / Ubuntu 14.04 64 bit setup. Thank you.
    – michael
    Aug 25, 2015 at 2:34
  • Finally, something that actually worked! :-) Ubuntu 14.04 on Ubuntu 14.04 host. May 15, 2016 at 18:21

I had the same problem. I fixed it by installing the guest additions as explained in the other answers and jacking the amount of video RAM in the settings as shown. MateConfig

  • 1
    After several hours of try with all other options (installing guest addons, updates etc.) I realized that this is the problem..
    – endo64
    Apr 21, 2016 at 13:56
  • 1
    Thanks a lot!! It should be the first thing that the user have to check! I waste half a day to trying to figure out how to fix it and tried a 1000 ways... Eventually, you saved my day, thanks!
    – Sirop4ik
    Dec 20, 2019 at 12:15
  • @AlekseyTimoshchenko I'm glad it worked for you as well!
    – Elder Geek
    Dec 20, 2019 at 14:04

Sometimes, simple solution could be:

enter image description here

  • HAHA Worked like a charm!!! Did not install guest additions or jump through any other special hoops like other answers recommend. Jul 7, 2018 at 0:03

I remained stuck for several days in low screen resolution in a Ubuntu 14.04 guest running on VirtualBox 4.1 on Debian Wheezy. None of the most commonly suggested solutions (e.g. installing virtualbox-guest-dkms, installing guest additions) helped. Installing VirtualBox from the official downloads page worked!


To expand on what Sylvain Pineau said, typing the following command is much easier (wildcards are accepted with apt-get):

sudo apt-get install virtualbox*
  • 3
    But it will install packages like virtualbox-source, virtualbox-dbg and older versions (such as virtualbox-2.2) depending on your ppa settings Jan 26, 2015 at 20:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .