I have upgraded from 12.04 to 14.04 on my laptop. The upgrade was successful, but the issue is that nothing happens now when I click on "LogOut", "Shutdown", "Suspend" from the top right power icon (not sure if this is the proper name); "Systems Settings", on the other hand works and launchs the associated window. Not a big issue, though, since I can logout and shutdown from a terminal, but I'd like to know why is this not working and how can it be fixed. Any ideas on how to solve this?

  • Does the machine shut down when you type dbus-send --system --print-reply --dest=org.freedesktop.Hal /org/freedesktop/Hal/devices/computer org.freedesktop.Hal.Device.SystemPowerManagement.Shutdown on a terminal? – jobin Apr 23 '14 at 22:11
  • @Jobin No. I get the message Error org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Hal was not provided by any .service files. – Gonzalo Medina Apr 23 '14 at 22:23
  • 2
    Does the machine shut down when you type dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1.Manager.PowerOff" boolean:true on a terminal? – jobin Apr 24 '14 at 5:40
  • 2
    It seems that this bug is still valid then. As @fossfredom suggested you can flag your question if needed. – Sylvain Pineau Apr 24 '14 at 13:38
  • 1
    @fossfreedom According to comments, it is indeed a bug, and Sylvain Pineau has found it here. You suggested to flag to close and return the bounty but, if there's no problem, I'd like to accept Jobin's answer below and award him the bounty. – Gonzalo Medina Apr 24 '14 at 14:21

As Sylvain Pineau pointed out, it seems that you this bug affects you.

The best way you can enable shutdown/logout/suspend in the cogwheel menu is disabling starting cairo dock at startup and then manually starting it(you can type "cairo dock on the dash and then click it to start cairo dock).

Another workaround for the moment until the bug gets fixed is using a keyboard shortcut to shutdown. For that open System settings -> Keyboard -> Shortcuts and set a "Custom Shortcut" as follows:

  1. Click on +

  2. Type "Shut down" ahead of "Name"

  3. Type

    dbus-send --system --print-reply --dest=org.freedesktop.login1 /org/freedesktop/login1 "org.freedesktop.login1.Manager.PowerOff" boolean:true 

    ahead of "Command" and click "Apply"

  4. Click on "disable" in front of the shortcut created and press the keystrokes you want to be set for shutting down, if they are already used, you'll be warned, if not you can use that keystore for shutting down without having to enter the password as you now do using sudo pm-poweroff.

For a list of other commands for rebooting, suspending and hibernating refer to this question:

You can similarly create shortcuts for other commands.

  • 2
    You have my vote for having found the relation with cairo dock, congrats. – Sylvain Pineau Apr 24 '14 at 14:01
  • @SylvainPineau: Thanks for pointing out it was indeed a bug, had been scratching my head for a while now. – jobin Apr 24 '14 at 14:18

No need to remove cairo-dock from start-up applications, find cairo-dock.desktop file ~/.config/autostart and add this code,X-GNOME-Autostart-Delay=20

Steps to solve easily (tested in Ubuntu 14.04)

  1. run gedit without root
  2. click open file menu and press Ctrl+H
  3. open file ~/.config/autostart/cairo-dock.desktop
  4. add this


  1. save and close

  2. reboot your unity/gnome

Delay time more than 20 works fine.

soure here


In 14.04, such actions should use /org/freedesktop/login1 provided by systemd-logind. try to reinstall the indicator-session package.

Open a Terminal an type:

sudo apt-get update
sudo apt-get purge indicator-session
sudo apt-get install indicator-session systemd-services

indicator-session roles are described here: https://wiki.ubuntu.com/SystemMenu

  • Jobin's comment suggests that this might be the problem. I tried his suggestion and the computer does shutdown. I tried reinstalling indicator-session as you suggested, but the problem is still there. – Gonzalo Medina Apr 24 '14 at 13:11
  • I reinstalled indicator-session and now it won't show up unless I manually launch it. – RolandiXor Nov 10 '14 at 22:09
  • @RolandiXor: OP problem was related to cairo-dock. Now if the indicator has to be started manually, just add it to the Startup Applications Preferences. On my system the command is /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service – Sylvain Pineau Nov 10 '14 at 22:15
  • I just realized the issue was related to a bug where it's not shown in Pantheon. I don't use Cairo-Dock btw. – RolandiXor Nov 10 '14 at 22:17
  • @RolandiXor: It's an old question, but you could leave the bug number here for reference. – Sylvain Pineau Nov 10 '14 at 22:19

Instead of Removing cairo dock from Startup Applications, you can also change when it starts up... I have found that 60 seconds (on my laptop at least) is sufficient time to allow for the system to start properly prior to starting cairo dock. the following in the Command field will allow for delayed startup.

sh -c "sleep 60; exec cairo-dock -o"

You can play with the sleep time to minimize it based on the speed of your system :)

This allows the system to startup and the shutdown etc options still exist


I saw this problem on different machines after upgrading from 12.04 to 14.04. To fix I had to issue sudo pam-auth-update --force

Relevant bug: https://bugs.launchpad.net/ubuntu/+source/policykit-desktop-privileges/+bug/1240336

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.