When I open my session, the wallpaper changed to the default one and I can't change any settings. When it happened for the first time I was running on Ubuntu 13.10, I have upgraded to 14.04 LTS hoping that it would fix the problem, but unfortunately it didn't.

  • Where is your desktop wallpaper located? What do you mean you can't change any settings?
    – Parto
    Apr 21, 2014 at 12:47

2 Answers 2


I fixed the problem by deleting the .cache .compiz and .config folders from my home folder.

  • Just to confirm that this works. I had the same issue (not being able to change any user settings and few other annoyances). I spent almost entire day trying various things with no success. Deleting .config and .cache folders magically repairs everything. Thank you man..
    – multipole
    Aug 6, 2019 at 23:47
  • I love you so much!
    – Gal Shahar
    Nov 18, 2020 at 8:50

When I encountered this issue it turned out I mistakenly changed the ownership of the "user" file in /home/{my user}/.config/dconf/. Changing the ownership of /home/{my user}/.config/dconf/user back to {myuser}:{my user} fixed the issue, e. g.:

sudo chown dennis:dennis /home/dennis/.config/dconf/user

I figured out where the issue was by tailing /home/{my user}/.cache/upstart/unity-settings-daemon.log while trying to change settings.

(unity-settings-daemon:2157): dconf-WARNING **: failed to commit changes to dconf: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code2: Cannot open dconf database: Failed to open file '/home/dennis/.config/dconf/user': Permission denied

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .