15

When I start the Ubuntu ISO(13.10) on a USB, initramfs says "unable to find a medium containing a live file system".

These are my PC specs: http://pcpartpicker.com/user/PoniesFiM/saved/39dy

I have Windows 8.1(64 bit, with Update 1) installed on this computer. Other computers that I tried with the same USB didn't give the error.

What I tried to fix this:

  • Switching from IDE to AHCI(I already did it before on this computer).
  • Using other USB ports.
  • Switching from USB 3.0 to 2.0(and backwards).
  • Switching from UEFI to Legacy(and backwards).

Nothing that I know works right now. Are there any possible solutions?

3
  • Usually this is a bad download. Check the m5sum of the iso – Panther Apr 20 '14 at 22:42
  • I did check the md5sum of the iso and the program I used said the md5sum of the iso was the same of the md5sum from the Ubuntu servers. – PoniesFIM Apr 21 '14 at 0:29
  • 1
    The link you provided states that you are using a Gigabyte mainboard, which seem to have problems with the IOMMU: askubuntu.com/a/571242/40581 – LiveWireBT Jan 8 '15 at 9:07
16

Using Ubuntu 17.04 ISO on a SanDisk 32GB USB stick. My m/board is ASROCK B250M. None of the suggestions I read online worked for me. I noticed, though, that the USB stick was mounted when I pulled it out and plugged it back in, so when the installation was showing the Ubuntu 'wait' screen with flashing dots, I figured it was looking for the installation media, so I pulled out the USB stick and pushed it back in. Hey presto! - the installation media was found and I managed to install Ubuntu.

7
  • 3
    The same worked for me. I pulled it out as soon as the flashing dots came up. – Michael Mulqueen Sep 14 '17 at 14:52
  • 2
    same working for me, really strange, but only in linux in windows detect automatically – Jonathan Rodriguez Feb 8 '18 at 20:16
  • SanDisk 32GB USB stick here, with the same symptoms and same workaround. Perhaps there's something wonky about that particular USB stick. – vegai Aug 26 '19 at 5:59
  • SanDisk 32GB here, too. An older one that slides back and forth to reveal either USB-A or microUSB. This solution works for me as well. Too strange... – SaintWacko Dec 17 '19 at 22:11
  • 1
    Oh thank you! I created an account just to thank you as I'd never have realised this was the problem. Works for me now I've switched to another non-SanDisk USB stick. (For Ubuntu 20.04 the screen where you need to pull out/reinsert now has a rotating logo, instead of flashing dots.) – Stevo Jul 6 '20 at 12:41
7

I had the same problem, trying to boot Ubuntu Mate 14.04. For me, enabling the IOMMU Controller in the BIOS solved the problem. Press 'Del' to enter the BIOS, then go to 'Peripherals' --> 'IOMMU Controller' --> 'Enabled'. Worth a try.

My motherboard: Gigabyte 990XA-UD3

2
  • 1
    If you have a Gigabyte Mobo please try this. Nothing else worked for me until I got to this reply right here, which solved my issue. Thanks Krisztian! – Brian Jan 10 '18 at 23:26
  • Same mobo here. This problem appeared one day and refused to go away. I enabled the iommu controller and everything started working again. Than you! – Forestrf Nov 19 '20 at 23:57
3

I had the same problem on Ubuntu 16.04 Desktop x64 iso file (14.04 does not make any problems). File integrity is ok, but having the same issue. I have solved that issue by using my pen driver on a USB 3.0 port rahter than USB 2.0. Just thought it might help.

0

Was having the same problem and while looking for the AHCI compatibility setting in the bios I came across one that stated something along the lines Restrict OS installation. The options being Windows/Other. I switched over to Other and presto!

Have a close look at all your bios setting as it may be this simple!

0

I had the same problem and what have helped was to change the pendrive on which I have saved the ISO file.
It is wired because with the first pendrive I have successfully installed Ubuntu on three different computers. With one computer I had a problem and changing the pendrive helped.

Computer with win xp (32 bit)
BR

0

I also had the same problem and what solved it in my case was using MultiSystem rather than UNetbootin

MultiSystem can be found here: http://www.pendrivelinux.com/multiboot-create-a-multiboot-usb-from-linux/

Also check out this question for other ideas on how to solve this problem: Error when installing: "unable to find a medium containing a live file system"

Hope this helps, Kind Regards, Tord

0

Had the same problem on an HP notebook.. Tried everything suggested on all the forums, bios settings, different USB flash drives.

Could not get it to either load live nor install.

Then someone suggested pulling out the USB drive while the dots are flashing as if its looking for something, then reinstalling it into the same port.

That did the trick. Did it on multiple laptops/notebooks with success.

I think that something hasn't released the drive so the installation can continue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.