I have a lenovo g505s graphics card is Amd radeon hd 8550g with windows 8.1 pre installed (not my favorite os). I disabled secure boot, changed uefi to legacy mode. Then I loaded and successfully installed ubuntu alongside windows.

When the computer restarted it brought me to the grub menu, when I select ubuntu I get a frozen purple screen... if I try secure mode I get the same purple screen with "loading linux 3.13.0-24-generic than loading initial ramdisc..." and it freezes.

I have tried pressing e and changing quiet splash with nomodeset, and I still get a purple screen of death. I know that its probably a graphics card issue but have no idea how to fix it...

Please help

  • Reinstalling your AMD drivers should do the trick.
    – Joren
    Apr 20, 2014 at 21:22
  • Boot into Verbose Mode and post logs so we can help you.
    – Cody
    Apr 20, 2014 at 21:49
  • Ya, Fear I may have screwed this up even more. Went to reinstall ubuntu to see if that was the problem. deleted the partition containing ubuntu (prob a big mistake), and now if I try to run through legace mode nothing will boot up at all claiming the partition is not there. How do I completely uninstall Ubuntu? I dont understand why windows only boots up in uefi mode, and ubuntu would only boot up (when it worked) in legacy mode.
    – user271651
    Apr 21, 2014 at 2:46
  • You can use UBCD to get to your partition table, to delete and create what you need to be able to reinstall Ubuntu. UBCD fits on a regular CD and it is a bootable rescue CD. After you boot the CD, you can go to HDD-Partition Management section and choose Gparted or Cute partition manager to be able to do what you need to do.
    – Taz D.
    Apr 21, 2014 at 14:13
  • This is a bug (possibly related to bug #1301839 or bug #1290745). Please open a bug report on Launchpad. (You may be able to workaround this bug by first installing Ubuntu Server, then doing a full update, and if it still does not work install Catalyst)
    – bain
    Jun 19, 2014 at 10:02

3 Answers 3


I happen to own the same model and ran into the same problem. I have tried everything starting from editing grub, installing different kernels, trying proprietary drivers, converting to efi partition, booting with battery ejected.

After 6 months of trying, I find it weird to say that what solved problem was moving network boot to top of boot order (with BIOS in legacy mode).

Yes it sounds crazy but it works now. Flawlessly. Every time.

  • switching the boot order by putting network boot to the top of boot order worked for my Len 505s. Thanks.
    – user360791
    Dec 21, 2014 at 17:27
  • I have the same model and this also worked for me... which really doesn't make any sense seeing as how my initial working installation didn't need this but my dual-boot one does.
    – Gramps
    Jan 16, 2015 at 17:22

Boot into the rescue mode and run dpkg to try to fix any broken package that you may have. When you're finished and get back to the screen with options in rescue mode, choose the enable network option and see if you can run some codes in the terminal console, after you login, something like:

      sudo apt-get update   or

      sudo apt-get upgrade

If you can get somehow the Internet to work, you can try to run these commands:

      sudo apt-get install xubuntu-desktop

      sudo apt-get install lightdm-greeter 

LightdDm greeter should be installed by the previous command but you never know. Finally you can run this command:

      sudo apt-get remove unity-greeter

Reboot and you should be able to get past the freezin screen and login using lightdm greeter.

Next you can try installing with Synaptic the so called lowlatency linux headers and the linux image. First you should install synaptic either from the Software Center or in a terminal window:

    sudo apt-get install synaptic

Next you can open Synaptic Package Manager and type kernel in the search field or better use the search button with kernel as keyword. Once you get the results, look for and install the same version of linux image and linux headers with your present ones. What you need is linux-image-3.13.0-24-lowlatency and the linux-headers-3.13.0-24-lowlatency. Pay attention to match the numbers for the kernel which is something like 3.13.0-24-28 or it can be 3.13.0-24-46 or something else. You want to install the exact same version of the lowlatency linux headers and image with your linux image generic and the generic linux headers.

After you're done you can run in a terminal window this code:

    sudo update-grub

Grub is updated during the installation but you can do it again just to make sure you keep things in good order. After reboot you can choose to boot the lowlatency kernel instead of the generic kernel using Advanced Option for Ubuntu.

This method works for both 32bit machines and 64 bit machines. The word out there is that it works better for Ubuntu 64bit but it worked ok for me too, I am running Ubuntu 14.04 32bit.

  • Rescue mode = Recovery mode? when i went into recovery mode it froze as well, just with two lines in the top left corner instead of just a purple screen.
    – user271651
    Apr 21, 2014 at 2:47

Double error in Ubuntu 14.04.1 and Lenova Bios. Please, read the original article http://strnor.ru/?p=934 To be short: you need FAT32 partition /dev/sda1 atleast 512M with mount point /boot/efi with nothing inside EVEN FOR LEGACY BOOT MODE. It works for me.

  • 2
    I'm sorry, but this is a English Q&A page. Linking non-English article won't help.
    – MadMike
    Oct 22, 2014 at 5:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .