I never understood why the nvidia-173 and/or nvidia-96 driver packages come together with some useless nvidia-settings showing a different version from the original driver like 'nvidia-settings 304' or 'nvidia-settings 331' or any other wrong version except for the actual nvidia-settings-173 which is needed for the nvidia-173 drivers to work.

I can't use 'nvidia-settings' after installing nvidia-173 video drivers from Ubuntu repos to change resolution or monitor frequency for the simple reason that together with these drivers comes a different version of 'nvidia-settings'than the one needed by 'nvidia-173' driver to work. The same thing happened to me a few years ago when using a different video card which needed the 'nvidia-96' driver package.

I am sure this is not a bug because Microsoft's finest are using for decades the same policy to push us, the little people, to change our ancient "hardware". I suppose there is not much to do to make nvidia-settings work with 'nvidia-173' drivers except to download a driver from nvidia support page and install it the hard way?

And this is most difficult or even impossible to be done in Ubuntu 14.04 because I suspect I need a patch or something close to it to be able to install a suitable driver (downloaded from nvidia.com website) for my video card.

  • In Ubuntu repos latest Nvidia driver is 331 which works with nvidia-settings.
    – Cornelius
    Apr 20 '14 at 21:16
  • Give it a try! As long as it is tested...
    – Cornelius
    Apr 20 '14 at 21:19
  • I thought it is shown. For my GeForce 8600GT this is the latest driver.
    – Cornelius
    Apr 20 '14 at 21:27

Solved it Myself This Way

I have found an unorthodox but working solution to link nvidia-173 to its native nvidia-settings package. As always, Debian developers and maintainers will fix almost anything because they are still the best out there. There is a .deb package for nvidia-settings-173.14.39 32bit available on this page. If you need the 64bit package, you can find it on this page.

Unfortunately, there is no way Gdebi will install the .deb package but fortunately there is a solution to make the correct 'nvidia-settings' package version 173.14.39 work with the nvidia-173 driver from the Ubuntu repositories.

Use this solution only after you install/activate the nvidia-173 driver package present in the Ubuntu repositories. It will work for any version of Ubuntu 32bit, Ubuntu 14.04 included.

First thing to do is to completely remove the useless nvidia-settings version 331 or whatever version comes together with nvidia-173 driver package. This can be done using Synaptic or from a terminal window:

  sudo apt-get remove nvidia-settings

and after that you can run

  sudo apt-get autoremove

to remove the rest of the packages which are incompatible with nvidia-173 like 'nvidia resolution extra' and similar.

Next you can download the nvidia-settings-legacy-173xx_173.14.39-1~bpo70+1_i386.deb package from the link provided above, and extract the files in a temporary folder named nvidia in your user home directory.

Inside the .deb archive there are 2 folders, one is named DEBIAN, and contains files that are not needed for the actual job, so leave it as it is. The other folder is labeled USR and this one includes both the .png image file useful for editing the nvidia-settings.desktop file, and also includes the actual nvidia-settings files which are present in a subfolder from the archive, namely inside USR/lib/nvidia/legacy-173xx.

You should log out and login again as root, and copy all the files except for nvidia-settings.desktop file from nvidia temporary folder to this folder:


I am talking of course about files contained inside the temporary nvidia folder from your user home directory which are located in USR/lib/nvidia/legacy-173xx.

Next you have to copy the nvidia-settings.desktop file to


and edit this file to look like this:

  [Desktop Entry]
  Name=NVIDIA X Server Settings
  Comment=Configure NVIDIA X Server Settings

Next you must copy the nvidia-settings-legacy-173xx.png image file from your nvidia temporary folder located in your user home directory (the image file is present in USR/share/pixmaps/) to:


Finally, navigate to /usr/lib/nvidia-173/ and right-click the 'nvidia-settings' file and make a shortcut for this file (choose 'Send to Desktop' from the right-click menu). Move 'nvidia-settings' shortcut from your desktop to /usr/bin/. If you choose just to copy-paste the file, you should delete 'nvidia-settings' shortcut from your desktop after you finished copying the file inside /usr/bin/.

It won't be difficult because, remember, you are still logged in as root. After you finished with all that, you can log out, and login again with your usual username and password.

And you're done. You can access 'nvidia-settings' from your Settings Manager or you can open 'nvidia-settings' if you type in a terminal window the following code:

   sudo nvidia-settings

You can change all settings that you think you need to change, and Power Mizer will also be active and functional.

NOTE: I did not test this solution with Ubuntu 64bit. If, after activating the driver, there is a folder named nvidia-173 present in /usr/lib/ then I suppose it could work for 64bit version too. If nvidia-173 folder is located somewhere else or labeled with a different name then you should adjust the commands and the entries for editing nvidia-settings.desktop file accordingly.

  • good workout, drivers of 173 version are still available at official geforce website also geforce.com/drivers I also use old video card and its native driver version is 173, I used it on Ubuntu 12.04 downloaded from Geforce website and it worked fine. Good workout though :-)
    – JoKeR
    May 24 '14 at 17:14
  • Nvidia drivers from nvidia.com or Geforce website won't work in Ubuntu 14.04. It is the reason I had to come out with this "out of the box" solution to make nvidia-173 driver package work with its native nvidia-settings. I also filed some complaint on launchpad.net but they have no interest in solving the problem..too much work and no pay make Jack a grumpy guru.. .
    – Taz D.
    Aug 31 '14 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.