2

I tried updating to Ubuntu 14.04 today, but Software Updater seems to be having some issues. First of all, I get the following message while the updater is preparing the update:

Third party sources disabled

Some third party entries in your sources.list were disabled. You can re-enable them after the upgrade with the 'software-properties' tool or your package manager.

I'm not sure if this is an issue, but it seems suspicious. Then, when the updater moves on to setting new software channels, the entire process stops and I get this message:

W:Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_source_Sources Hash Sum mismatch , W:Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_main_binary-amd64_Packages Hash Sum mismatch , W:Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_trusty_universe_binary-i386_Packages Hash Sum mismatch , W:Failed to fetch http://archive.canonical.com/dists/trusty/Release Unable to find expected entry 'parter/binary-amd64/Packages' in Release file (Wrong sources.list entry or malformed file) , E:Some index files failed to download. They have been ignored, or old ones used instead.

I would like to update to 14.04 and this is preventing my update. Help would be greatly appreciated.

5

I have to comment here because I still don't have enough reputation to comment. How have you tried to upgrade the release?

Have you changed your sources.list in the past?

Go to this site http://repogen.simplylinux.ch/ and chose your country, release and the Ubuntu branch and updates.

Then open a terminal and write "sudo do-release-upgrade".

Is it correct to assume you are using 13.10?

  • Thanks so much! I think it's working so far. I followed the website and retried the upgrade and it's actually moving past the step with problems. It's downloading and upgrading packages now so I'll post an update once it's finished. I also saved my old sources.list file just in case. – AxolotlEmu Apr 20 '14 at 21:59
  • Can confirm working as well +1 to you sir. – ehime Apr 22 '14 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.