So I tried updating my system, to find this pop-up error upon attempt,

The package system is broken

Check if you are using third party repositories. If so disable them,
since they are a common source of problems. Furthermore run the
following command in a Terminal: apt-get install -f

I ran the command under sudo in the command prompt, to find this issue,

Reading package lists... Done Building dependency tree        Reading
state information... Done Correcting dependencies... Done The
following packages were automatically installed and are no longer
required:   nvidia-settings-updates libudev0:i386 Use 'apt-get
autoremove' to remove them. The following extra packages will be
installed:   tor Suggested packages:   mixmaster xul-ext-torbutton
socat tor-arm apparmor-utils The following NEW packages will be
installed:   tor 0 upgraded, 1 newly installed, 0 to remove and 243
not upgraded. 1 not fully installed or removed. Need to get 0 B/1,097
kB of archives. After this operation, 2,571 kB of additional disk
space will be used. Do you want to continue [Y/n]? y (Reading database
... 388724 files and directories currently installed.) Unpacking tor
(from .../tor_0.2.4.21-1~precise+1_amd64.deb) ... dpkg: error
processing /var/cache/apt/archives/tor_0.2.4.21-1~precise+1_amd64.deb
(--unpack):  trying to overwrite '/usr/bin/tor', which is also in
package tor-browser 2.3.25-12 dpkg-deb: error: subprocess paste was
killed by signal (Broken pipe) Processing triggers for man-db ...
Errors were encountered while processing: 
/var/cache/apt/archives/tor_0.2.4.21-1~precise+1_amd64.deb E:
Sub-process /usr/bin/dpkg returned an error code (1)

What can I do to fix this error and get my update underway?

  1. After you get that error, try sudo apt-get -f install to force an

install of the files that didn't get loaded because of the error.

Then try sudo apt-get update again, sudo apt-get -f install back and forth until only the package that has the error is left.

sudo dpkg --configure -a

and clean the cache

sudo apt-get clean

Remove tor-browser package and fix the dependencies.

sudo dpkg -P tor-browser
sudo apt-get install -f

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.