7

I upgraded from 12.04 to 14.04, and notice a different behaviour in multi-monitor mode. In 12.04, when I plugged in the external monitor and then closed the laptop lid, the laptop would not suspend and I could work with the external monitor, but when I removed the external monitor, I could suspend by closing the lid. In 14.04, when I close the lid the laptop suspends. I want to get back to the original behaviour: i.e.: close lid when monitor present = do nothing; close lid with no monitor = suspend.

This question How can I tell Ubuntu to do nothing when I close my laptop lid? gives solutions to always prevent the laptop from suspending, my question is specifically about different behaviours depending on whether a monitor is attached.

My laptop is a Thinkpad Edge 13 with Intel integrated graphics

(I found a similar question but referring to Ubuntu 11.04 Problems with external monitors on my laptop , the answer mentions a problem with the kernel)

2
  • I am having the exact same issue. When I connect an external monitor and close the lid, the screen blanks of both the laptop and the external monitor. I have changed the settings in power to do nothing. But that does not seem to work. This used to wok in 12.04, but not any more? Is this intended behaviour?
    – user219015
    Apr 27, 2014 at 8:02
  • Please consider filing a bug for this by typing ubuntu-bug unity, then paste the link here and i will for one mark it as "Affects me".
    – v010dya
    Oct 22, 2014 at 16:30

1 Answer 1

2

I believe this is a bug, and the only solution is to set your options to "Do Nothing".

Quite simple really

go to System Settings Then click on Power Settings

Set the When the Lid is Closed options to Do Nothing

You can now close your lid and your laptop will not shutdown.

If your external monitor goes black just move your mouse or click mouse button and it should turn back on, and your external monitor will now be your primary display.

PS. You should also file a bug report for this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.