0

Fresh install of ubuntu 14.04 on a touchscreen Toshiba Satellite laptop with intel graphics. I tried to follow the fix here:

Why does kworker cpu usage get so high?

It didn't work; my problem seems to be on gpe10, which lists as follows:

/sys/firmware/acpi/interrupts/gpe10:11042017   enabled

This only takes up about 32% of one of my cpus (there are 4 available), but it shouldn't be running that high and I want it gone. As stated, the fix above didn't work; after reboot, nothing happened. I even tried running crontab as root, but that did nothing.

1
  • Same problem, Kworker 100% cpu, take 35 % cpu on my i5 (4 cpus). Load avg: 11 The problem start when i launch a virtualbox. It was ok on Ubuntu 12.10 and cpu issue start after upgrade to ubuntu 14.04. I try a fresh install and i got the same problem – user3473115 Apr 21 '14 at 19:27
0

Ok, I think I solved the problem. I'm going to leave my previous non-answer in place because I believe it has useful information. Or at the very least it has keywords which will help people find this answer.

The problem was that noclobber was set in rc.local, so it wouldn't add disable to gpe10. I solved that by adding two lines to rc.local. Issue the command:

sudo gedit /etc/rc.local

And then append the following two lines BEFORE the "exit 0" line:

set +o noclobber
echo "disable" > /sys/firmware/acpi/interrupts/gpe10

Hope that helps someone.

Not the answer you're looking for? Browse other questions tagged or ask your own question.