is it possible to get multitouch gestures in ubuntu 14.04 like macbook? if possible how to activate or install multi touch gestures ? my laptop is lenovo z580.it has syanptics touchpad which supports multi touch of 4 fingers as of my knowledge. i tried touchegg but no use.

up vote 14 down vote accepted

Yes, it is possible:

Installation

  • install touchegg: sudo apt-get install touchegg
  • install Touchegg-GCE: You have to git clone (or download) Touchegg-GCE from github and then manually compile it, it needs qt4 so sudo apt-get install qt4-dev-tools then open a terminal into the Touchegg-GCE directory and type /usr/bin/qmake-qt4 and make. Now launch touchegg-gce and configure your gestures.

    Autostart and configuration: into ~/.config/autostart/

  • create an executable (chmod +x touch.sh) script touch.sh with the following code. It is necessary to disable the default behaviour of the trackpad for 2-3 fingers gestures

    #!/bin/bash
    synclient TapButton2=0
    synclient TapButton3=0
    synclient ClickFinger2=0
    synclient ClickFinger3=0
    synclient HorizTwoFingerScroll=0
    synclient VertTwoFingerScroll=0
    
  • create two launchers: one for the script(1) and the other for touchegg(2).

    (1) touch.desktop

    [Desktop Entry]
    Type=Application
    Exec=/home/<user>/.config/autostart/touch.sh
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[it_IT]=TouchScript
    Name=TouchScript
    Comment[it_IT]=Enable Touchegg 2-3 fingers
    Comment=Enable Touchegg 2-3 fingers
    

    (2) touchegg.desktop

    [Desktop Entry]
    Name=Touchegg
    GenericName=Touchégg
    Comment=Touchégg Gestures Manager
    Exec=/usr/bin/touchegg %u
    Terminal=false
    Type=Application
    Name[it_IT]=touchegg.desktop
    
  • 2
    Does this work in Unity? Or it must be Gnome like the next answer? – victorhqc Mar 26 '15 at 21:05
  • I don't see this directory after I run the install command: /usr/bin/qmake-qt4 What do? I'm using Unity, not Gnome – GoProCameraByGoPro Apr 2 '15 at 4:20

I have not been able to get multitouch gestures support with touchegg on Unity. However, after installing Ubuntu Gnome 14.04, touchegg works like a charm.

  • 1
    where you be able to get four finger touch like macbook ?? and could you please explain the steps to install and configure touchegg for multitouch?? – dharmesh Apr 26 '14 at 7:28
  • I have corrected my answer above. I had forgot the "not". With touchegg on Ubuntu Gnome, I have been able to get four fingers touch. You can install it from ubuntu repo. – Jean-Louis Jouannic Apr 27 '14 at 14:35
  • I guess you meant "I have been unable" or "I haven't been able". Double negatives in english are interpreted like in formal logic, and your first sentence implies you have achieved multitouch gestures on Unity ;) – jesusiniesta May 4 '14 at 16:28
  • Damn! You are right! Fixed. – Jean-Louis Jouannic May 5 '14 at 19:10
  • @Jean-Louis, could you explain how you got it to work? It would be much appreciated :) – Rasmus Jun 12 '14 at 21:20

I have ubuntu 14.04 and using a logitech mini-keyboard with touchpad I have gestures enabled by default, I didn't installed anything specific. Using two fingers I can zoom in/out or scroll pages.

Edit: I tried also on an other system in a HP laptop, so I really believe that basic gestures are now active by default in ubuntu 14.04

  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Pilot6 Sep 22 '15 at 16:00
  • @Pilot6: thank you, but in this case the "new question" was very secondary, the main motivation to reply to the question in the thread was to bring my experience that basic multitouch in ubuntu 14.04 is enabled by default.. – Antonello Sep 22 '15 at 20:07
  • @Antonello: that's not very clear from your description. Please edit your answer, provide some screen shots on how to enable it, ... Otherwise your answer will be deleted automatically by the system because of low quality soon... – Fabby Sep 22 '15 at 22:12

You should try xSwipe! Works very effective

protected by Community May 14 '14 at 9:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.