130

I just installed Ubuntu 14.04 and I can't mount my exFAT HDD.

I get the following error:

Unable to access “SeagateHDD”
Error mounting /dev/sdb1 at /media/me/SeagateHDD: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sdb1" "/media/me/SeagateHDD"' exited with non-zero exit status 1:
stdout: `FUSE exfat 1.0.1
'
stderr: `ERROR: `Operating Systems' has invalid checksum (0x281c != 0x2450).
'

I installed exfat-utils and exfat-fuse using apt-get but no luck. I also tried the repository ppa:relan/exfat but I got:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 fuse-exfat : Depends: fuse-utils (>= 2.7) but it is not installable
E: Unable to correct problems, you have held broken packages.

Can anybody give me a hint? All my backed up data is on that HDD.

EDIT:

The output of $ sudo apt-cache policy exfat-fuse is:

exfat-fuse:
  Installed: (none)
  Candidate: 1.0.1-1
  Version table:
     1.0.1-1 0
        500 http://ppa.launchpad.net/relan/exfat/ubuntu/ trusty/main amd64 Packages

Tried it on a Linux Mint and had the same problem. Also tried mounting it on a Mac and it worked perfectly so the data is not corrupted.

EDIT2:

It appears it was a problem with my HDD which apparently I unplugged from the USB port without unmounting and it had a checksum error. What I did was I plugged it on my Mac and it automatically did a fsck_exfat disk check which fixed the problem and I could load it on Ubuntu as well. I think a similar thing could be achieved on Ubuntu as well, but I don't know which tools to use to do so.

200

Installing the below packages alone will auto-mounts your exFAT formatted drives ,

sudo apt-get install exfat-fuse exfat-utils

Or you may try to mount it manually after installing the above packages,

sudo mkdir /media/exfat
sudo mount -t exfat /dev/sdxx /media/exfat

/dev/sdxx - your exfat partition.

In Ubuntu 14.04, exfat-fuse and exfat-utils packages are available in Universe repository. So enable this repository inorder to install these two packages on Ubuntu 14.04.

sudo add-apt-repository universe

And don't forget to update all repositories,

sudo apt-get update
  • When I try to install fuse-exfat I get Depends: fuse-utils (>= 2.7) but it is not installable. However if I remove the ppa:relan/exfat ppa sudo apt-get install fuse-utils exfat-fuse works ok but still it doesn't mount. – Iuliu Apr 20 '14 at 14:45
  • make a restart. – Avinash Raj Apr 20 '14 at 14:46
  • doing right away – Iuliu Apr 20 '14 at 14:49
  • no success. After I remove the ppa:relan/exfat ppa executing $ sudo aptget install exfat-fuse exfat-utils outputs in Reading package lists... Done Building dependency tree Reading state information... Done exfat-fuse is already the newest version. exfat-utils is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. and $ sudo apt-cache policy fuse-exfat outputs in N: Unable to locate package fuse-exfat. – Iuliu Apr 20 '14 at 14:53
  • 2
    are there 2 different packages, fuse-exfat and exfat-fuse? – Iuliu Apr 20 '14 at 14:57
4

how about compile from source ?

# wget http://sourceforge.net/projects/fuse/files/fuse-2.X/2.9.3/fuse-2.9.3.tar.gz
# tar -xzvf fuse-2.9.3.tar.gz
# cd fuse*
# ./configure
# make
# make install
2

Just add the following PPA and install from the PPA:

sudo apt-add-repository ppa:relan/exfat
sudo apt-get update
sudo apt-get install exfat-fuse exfat-utils

and reboot your computer.

1

I had the same issue and I tried fuse and everything recommended in the forums with setting up/verifying fuse and trying to mount it manually but no luck.

The issue happened because I ejected the disk before unmounting it when my macbookpro got struck. So I used MacBook's Diskutility to repair it and it started mounting again in ubuntu with all my data intact.

1

Here is how I just made a perfect and clean installation of support for the exFAT file system type, to access my new micro SD card, in my Ubuntu 12.04 (64-bit, running on a Thinkpad T60, dual core, 2.0GHz and 4Gb ram, running on an internal Kingston SSD drive). All one need do is install Synaptic Package Manager, possibly by using the default package manager. Then, in the search box, type exfat. When I did this, only two items came to view in the list: exfat-utils and exfat-fuse. Now, put a check mark in both of these boxes by clicking with the mouse pointer (actually, I ticked the top one, and I got a message that both are required. When I closed the pop-up message, both boxes were ticked for me). Then, click apply. When the installation completed (very quickly and easily), I then opened my file manager. In the upper left I clicked the micro SD card that was previously not mountable. Immediately, the contents of the card displayed for the first time, since formatting the card to exFAT. I only had a test text file in it at the time, to help me determine what was going on. Now, everything is perfect, and I don't have to manually do anything (like mount and unmount). It is all automatic, like with cards formatted to FAT32. VOILA !!! All is well, now. Enjoy ! NOTE: I had reformatted my 512Gb generic micro SDHC class 10 card in Windows XP 32-bit, because at the time it couldn't be done with my Ubuntu system of then, prior to the above installation of exFAT support.

protected by Avinash Raj Mar 4 '16 at 12:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.